Jump to content
Corsair Community

Can't connect my H150i Pro to my motherboard?


JoshX
 Share

Recommended Posts

Hey guys,

 

I'm finally building my PC but I've ran into an issue. I'm using a Maximus X Hero board which comes with a usb called AIO_PUMP but it's only 4 pins and the H150i pro has 5 on the top and 4 on the bottom. Does anyone know how to connect this?

 

Thank you!

Link to comment
Share on other sites

Nevermind, was connecting the wrong thing I think, lol. (the image is huge idk why)

 

However, this happened. I'm not sure if it came like this or not, but can I just stick it back in? This is on the H150i Pro again btw.ljr84yL.jpg

Link to comment
Share on other sites

Well, that's less than ideal. It'll still work - this is just used to report fan speed to the CPU_FAN header so that you don't get a CPU Fan warning on boot. You may be able to stick it back in but a more proper repair would be to get the correct connector and crimp the cable on it. I think this is the connector: https://www.digikey.com/product-detail/en/0008500114/WM1114-ND. It does require a special crimp tool.
Link to comment
Share on other sites

Well, that's less than ideal. It'll still work - this is just used to report fan speed to the CPU_FAN header so that you don't get a CPU Fan warning on boot. You may be able to stick it back in but a more proper repair would be to get the correct connector and crimp the cable on it. I think this is the connector: https://www.digikey.com/product-detail/en/0008500114/WM1114-ND. It does require a special crimp tool.

 

Oh, thank you so much! I was thinking I'd need to buy a whole new AIO. Also, I plugged the case fans into the 3 connectors from the pump and then plugged the broken USB into AIO_PUMP. Should that USB go into CPU_FAN, and if so what should be plugged into AIO_PUMP?

Link to comment
Share on other sites

Oh, thank you so much! I was thinking I'd need to buy a whole new AIO. Also, I plugged the case fans into the 3 connectors from the pump and then plugged the broken USB into AIO_PUMP. Should that USB go into CPU_FAN, and if so what should be plugged into AIO_PUMP?

 

USB should go to the USB header. Your image was of a fan header, which is very different.

 

You don't need to plug anything into AIO Pump. That header is just a standard fan header that is set to 100% (Q-Fan Control disabled) by default. It really isn't anything special, just marketing labeling.

Link to comment
Share on other sites

 Share

×
×
  • Create New...