Jump to content
Corsair Community

SPEC-OMEGA RGB Case not showing in iCUE


ej1234
 Share

Recommended Posts

Hello everyone!

 

I recently bought my first rig and it's case is the Corsair Carbide Series Spec Omega Tempered Glass RGB Gaming Case, in Black/Black. It currently has a red lighting and I can't seem to find when I click on the + for dashboard or as one of the devices for iCUE. I did buy this rig from iBUYPower, so do I contact them? Any help is gladly appreciated!

 

Wv35L7A.png

 

Thank you

- E.J.

Link to comment
Share on other sites

Hi,

 

My spec omega rgb is instantly detected by Icue...

Did you connect the USB2 internal wire of the case on a free usb2 port of

your motherboard? that's the way the case is properly dectected by the system, and by Icue.

 

It's a flat black cable.

  • Confused 1
Link to comment
Share on other sites

  • Corsair Employees
From what it sounds like, you don't have the RGB variant of the SPEC-OMEGA. You can verify with iBuyPower to be certain, but if the front LED lighting is just solid red, it seems to be behaving like the non-RGB SPEC-OMEGA. If it was the SPEC-OMEGA RGB, it would've displayed a rainbow effect when you first booted up your system. Edited by Corsair CJ
  • Confused 1
Link to comment
Share on other sites

From what it sounds like, you don't have the RGB variant of the SPEC-OMEGA. You can verify with iBuyPower to be certain, but if the front LED lighting is just solid red, it seems to be behaving like the non-RGB SPEC-OMEGA. If it was the SPEC-OMEGA RGB, it would've displayed a rainbow effect when you first booted up your system.

 

I think you're right CJ. When I removed the right side panel, I can't find the USB that should be connected to the case. Also, when I look at the motherboard, there doesn't seem to be a usb at the usb header, but only at USB 3.0. https://imgur.com/a/avtWgm1

 

Either way, thank you for the replies everyone.

Link to comment
Share on other sites

 Share

×
×
  • Create New...