Jump to content
Corsair Community

ONLY Corsair devices disconnect / reconnect


Recommended Posts

Okay, so I'm hoping someone here can help me out here.

 

I have a Corsair Strafe RGB Keyboard, Corsair Glaive RGB Mouse, And the Void Pro Wireless headset and whenever I launch Fortnite (Haven't tried it with other games) randomly, sometimes it won't even happen, the devices I just mentioned will disconnect and reconnect indefinitely forcing me to restart my computer.

 

This recently just started happening as well, and I doubt it is an issue on Fortnite's end as users have complained in the past about devices Disconnecting and reconnecting.

 

I have tried troubleshooting as well, and here is what I have tried.

I moved the hub the devices are connected to, to another port, updated device firmware, updated windows 10 software, updated icue, unplugged and re-plugged back in. All have done nothing. Thing is while I'm on desktop and not in a game it doesn't freak out but only sometimes in game will it disconnect and reconnect.

 

Things to note: I have the devices plugged into a USB hub.

 

Here are my computer specs as well as the firmware versions on the devices. Hopping someone can give me some help on this.

 

Motherboard: MSI Z87-G45

GPU: MSI R9 390X (x2)

Processor: Intel Core i7-4790K @ 4.00 GHZ

RAM: Corsair Vengence 32 GB DDR3

PSU: EVGA 1000W G2

Keyboard Version:2.05

Mouse: 1.04

Headset: 0.15

Link to comment
Share on other sites

I have the same issue with my K70 RGB (2014-15 Model)

 

This started after CUE 2.24.50 prompted me that there is a newer version available which was iCUE 3.3.103. I updated it to iCUE and it all went downhill from there.

 

After the first reboot, my keyboard started to connect/disconnect continuously until I quit iCUE and put the keyboard in BIOS mode. I could use it in BIOS mode without any lighting effects etc, but I can't, because the keyboard kind of disconnects briefly after every 5-10 minutes, so during an intense gaming session, this is not good. I couldn't care less about CUE since after every update, something or the other breaks.

 

I removed cue, cleared appdata, cleaned registry, rebooted and downgraded to CUE 2.24.50 but the problem seems to have become permanent unfortunately. Thank you Corsair for the wonderful iCUE 3.3.103 update.

 

Contacted Corsair support and I was instructed the to do the same s*** again. Repeated it but the problem still persists. Even on reboot, windows refuses to boot unless I disconnect the USB of the K70 (Nope, doesn't even boot up in BIOS mode of the K70)

 

After a couple days, I tried CUE 2.24.50 again and I tried to check for the update. Guess what, it no longer redirected me to the webpage of iCUE 3.3.103. Instead it showed me 'software up to date'

 

I'm quite sure Corsair knew they ****** up but are not yet acknowledging the issue. I don't know how this is going to get fixed as my keyboard is out of warranty now. If this doesn't get fix, I know what brand to not go for. I feel cheated. I've been dealing with this issue since the past 2 weeks and I can't find a solution even on Google.

Edited by jigar7
Link to comment
Share on other sites

Loss of usb connectivity is usually going to be an OS level problem. While it may seem like an application conflict because it is only readily apparent when using certain programs, it is more likely the underlying issue is being magnified rather than created. You can try and pick apart logs and surgically attack different aspects, but for most people the best thing to do is a fresh install of the OS. Make sure you back up your C drive valuables and you will have to reinstall programs. It’s a pain, but less so than living with this indefinitely and expecting it to stop one day.
Link to comment
Share on other sites

  • 1 year later...
So I'm having the same issue, and I did a fresh install of windows, and that DID NOT solve the problem for me. I have a corsair crossfire keyboard, HS70 wireless headset, and a corsair hard mouse pad who's product name escapes me right now, and same as posted above, every 10-30 minutes it will all momentarily disconnect. I'm somewhat at a loss as to how to fix this issue as I thought a fresh install of Windows would definitely work. whether its an issue with the software update for iQue, or something else entirely, I'm at a loss for. So frustrating. downgrading also did nothing to help. If anyone has found a solution, please please please post a solution, because I'm refusing to play comp Overwatch with how annoying it gets! :evil: :mad:
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...