Jump to content
Corsair Community

Intermittent temporary loss of usb, keyboard and mouse stop, then reappear


Gypsycurse
 Share

Recommended Posts

Hi all,

 

I think I need some help.

 

When I run the Corsair Link or the new iCue I get an intermittent loss of usb devices, this happens at any time. Everything disappears from iCue then slowly reappears however obviously its pretty annoying.

 

I have checked the Event Viewer and the disconnection events are always preceded by an error with a Corsairservice. I have also tried running without Corsair link and over 2 days had no drop outs. However as you can imagine you dont buy this much RGB to disable it.

 

I have the following Corsair products:

 

AIO H150 Pro

AIO H115i

K95 Platinum

Polaris mm800 Mouse mat

ST100 headset stand

 

however I also have

 

ASUS Crosshairs VII hero

ASUS Strix Videocard

 

now I know ASUS can clash with Corsair so I removed AURA and rebooted, still the corsair service crashed.

 

Any suggestions would be welcomed. I'm at work at the moment but I'll attach some of the logs when I get home.

 

Thanks

Link to comment
Share on other sites

Some additional details before I forget, I'm using a commander pro and connecting both AIO into the USB headers on that. The commander itself is then connected directly to the MB into the unshared USB header(the ASUS board has two USB 2.0, and one is kinda shared)

 

Basically the system boots, runs, plays games etc, but ever so often the USB devices (namely pretty much the KB, Mouse, Headphones, etc) all disconnect. I am then left to watch and wait until around 20 to 30 seconds later they USB devices all pop back into life (even if by then my PUBG avatar has been popped in the head.

Link to comment
Share on other sites

You may want to do a basic removal of iCUE and the driver from Device Manager, reboot, and re-install. I have most of the same Corsair hardware also running though the C-Pro, which is the connection point back to the motherboard. I have not had this issue with any of the iCUE versions so far. Since the K95P, MM800, and ST100 don't use the same USB 2 pathway as the coolers, it is probably not port or line specific. Sadly, if the reinstall does not work, you probably need to look at the OS and that is always a pain to do a fresh install. I am running Aura as well and it sometimes might make the app hang, it has never caused a loss of connectivity.

 

So, is it just keyboard, MM800, and headphone stand that blink out? That might be a simpler thing. Did you daisy chain them together? Mine are too and it hasn't been an issue. Try a different USB port in the back. Some devices don't like USB 3.0.

Link to comment
Share on other sites

Thanks for your advice c-attack, so I uninstalled the corsair software, then removed the corsair XPdriver. I rebooted and reinstalled C-link4 then iCue ov er the top. WOrked for about an hour then:

 

Application: Corsair.Service.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: SIUSBXpWrapper.USBDeviceReadException

at SiUSBXpWrapper.SI_DeviceNative.InternalWriteAndRead(Byte[])

at SiUSBXpWrapper.SI_DeviceNative.WriteAndReadWithRestart(Byte[])

at SiUSBXpWrapper.SI_DeviceNative.WriteAndReadWithRestart[[system.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](Byte[], System.Func`2<Byte[],System.__Canon>)

at CorsairLink4.Module.AsetekCooler.AsetekPro.AsetekCoolerProDevice.Write(CorsairLink4.Module.AsetekCooler.AsetekPro.AsetekCoolerProOutputBuffer)

at CorsairLink4.Module.AsetekCooler.AsetekPro.AsetekCoolerProDevice.SetDirectLightEnabled(Boolean)

at CorsairLink4.Module.AsetekCooler.AsetekPro.AsetekCoolerProDevice.HandleDirectLight(Byte[])

at CorsairLink4.Module.AsetekCooler.AsetekPro.AsetekCoolerProDevice.ProcessControlData(CorsairLink4.Common.Shared.DevicesData.DeviceCommunicationData, System.Action`1<System.String>)

at CorsairLink4.Module.AsetekCooler.AsetekPro.AsetekCoolerProComponent+<InternalProcessControlData>d__9.MoveNext()

at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task)

at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task)

at CorsairLink4.Module.Common.BaseControlledComponent+<ProcessControlData>d__0.MoveNext()

at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task)

at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task)

at CorsairLink4.Module.AsetekCooler.AsetekCoolerComponent+<>c__DisplayClasse+<<InternalProcessControlData>b__d>d__10.MoveNext()

at System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c.<ThrowAsync>b__6_1(System.Object)

at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object)

at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()

at System.Threading.ThreadPoolWorkQueue.Dispatch()

at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

 

Faulting application name: Corsair.Service.exe, version: 3.2.0.18, time stamp: 0x5ac745dc

Faulting module name: KERNELBASE.dll, version: 10.0.17134.112, time stamp: 0xc863c6f9

Exception code: 0xe0434352

Fault offset: 0x0010db52

Faulting process ID: 0x17e8

Faulting application start time: 0x01d4055f03d065c4

Faulting application path: C:\Program Files (x86)\Corsair\Corsair Utility Engine\Corsair.Service.exe

Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll

Report ID: c4b6abf4-6da8-472a-a312-e5a7d46f89bd

Faulting package full name:

Faulting package-relative application ID:

 

The Corsair Service service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

 

The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Corsair Service service, but this action failed with the following error:

An instance of the service is already running.

 

and as per normal the two AIO and all peripherals disappeared, about 30 seconds later they reappeared.

 

Back to square one

Link to comment
Share on other sites

 Share

×
×
  • Create New...