Jump to content
Corsair Community

Void Pro Surround mic not working when connected to iCUE


Sepperoth0
 Share

Recommended Posts

So I'm having an issue with my wired version of the VOID Pro Surround - The mic stops working when CUE boots. I don't even have sidetone. Let me start by saying that this has been an issue since before I updated to iCUE - It was an issue even when I was using the regular CUE.

 

As soon as CUE loads, I hear the distinct "beep boop" of the headset's USB adapter connecting... Then I completely lose the mic. Unplugging and replugging the adapter doesn't fix it, (unless I close CUE first, in which case it works just fine.) To be completely clear: The mic works when CUE isn't running. CUE is what seems to be killing the mic. This is regardless of other programs or mic monitoring. The problem is that I'm also using a K95 RGB, a Sabre RGB, and an H80iV2. So simply not running CUE isn't really an option, because I'll be losing a ton of functionality with my keyboard, mouse, and CPU cooler.

 

I've tried using VoiceeMeter (a third party audio monitoring program) to actively monitor the mic volume, and have confirmed that CUE is indeed what kills it - As soon as CUE loads and connects to the USB adapter, I lose all audio signal from the mic. The mic volume is turned up all the way in CUE and in my system settings, and I've confirmed that it's unmuted. I've tried pushing a firmware update to the adapter, and that didn't help. I even tried completely reinstalling CUE, and that didn't help either; As I said before, this was happening even before I upgraded to iCUE.

 

Attached images are screenshots showing VoiceeMeter in image 1, (my webcam mic is input 1, and the headset mic is input 2,) and my system's sound settings in image 2, showing that my webcam mic is receiving audio but not my headset mic. Then image 3 (titled "Headset No CUE") is the same thing but after shutting down CUE and replugging the USB adapter. Clearly, CUE is stopping the mic for some reason.

New Bitmap Image.bmp

New Bitmap Image (2).bmp

Headset No CUE.bmp

Link to comment
Share on other sites

Namely' date=' checking to see if CUE is given permission to access the microphone. Windows added permissions recently in an update.[/quote']

 

No luck. iCUE doesn't actually show up on that app list, (probably because it's a program, not an app,) but my mic is given permissions using the global on/off at the top of the Microphone page.

Link to comment
Share on other sites

Hi there. Im having the same issue on this one.... please tell me something works???

 

I opened a support ticket with Corsair a few weeks ago. We're still troubleshooting. On the bright side, this at least tells me that my problem isn't just a fluke.

Link to comment
Share on other sites

  • 2 weeks later...

I did some more digging on my end, and tried simply running iCUE.exe as an administrator. That actually worked! But Windows won't let administrator programs automatically run at startup, and the UAC prompt whenever I manually run it is super annoying. So I found a workaround.

 

Instead of running the program as an administrator using the .exe's "Run as administrator" checkbox, I created a task in Windows' Task Scheduler, to run it via the command prompt, (which lets me add admin rights to it without a UAC prompt.) Next, to run that at startup, I created a shortcut for the task, and dropped that into my Startup folder.

 

So now when I log in, the shortcut in the Startup folder gets triggered. I get a brief cmd box flash on my screen, where it inputs the command to run iCUE.exe as an admin. Then iCUE starts as an admin, without a UAC prompt. Now my only issue is that iCUE launches in the foreground, rather than in the background. So I have to manually click the X to close the window. But honestly? After scratching my head about the startup/UAC thing for so long, I'm glad to just have it open at all.

 

Also, I don't actually need to run it in compatibility mode - It looks like Run as Admin is the key factor here.

Link to comment
Share on other sites

  • 2 years later...
  • 2 weeks later...
 Share

×
×
  • Create New...