Jump to content
Corsair Community

Dark Core never charged to 100%


Syberon
 Share

Recommended Posts

I found that my Dark Core never charges battery to 100%. After 2 days of continuous charging (i worked in wired mode) it's still show 75% at iCUE dashboard right after cable disconnection. Also i tried to use Qi charger and it works the same - after charging to 75%, mouse stops to charge and charger show that charge is complete.

 

I bought the mouse with defective battery and now need to RMA or is this a software bug?

 

http://f23.ifotki.info/thumb/c474ff76321aea76d1ad0f179626068a5efb79309963104.png

Link to comment
Share on other sites

as far as i know its a software issue.. i had this at the start with CUE 2.24.50 but i have seen it show 100% when using the early access iCUE 3.2.87

 

At this time i use iCUE 3.2.87 and it shows maximum 75%.

CUE 2.24.50 doesn't have dashboard - where do you saw charge level in percents in this version?

 

And another thing related to described issue - i can not determine when the battery is fully charged because it always shows the status of "charging"

Link to comment
Share on other sites

At this time i use iCUE 3.2.87 and it shows maximum 75%.

CUE 2.24.50 doesn't have dashboard - where do you saw charge level in percents in this version?

 

And another thing related to described issue - i can not determine when the battery is fully charged because it always shows the status of "charging"

 

yep, the constant charging state and not showing when fully charged is annoying..

 

the other one i noticed is that when you plug in the cable to charge the notification light on the side is meant to show you its charging state.. except you have to turn off the mouse to see it (ie. pulsing green light to see its charging etc).. so ridiculous

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
Try using the mouse til it goes dead, and then recharge it via wired.

 

bad advice dude...... its a Rechargeable Lithium-Polymer Battery.

 

Ni-cads and the like used to to suffer 'memory' and to stop them holding poor charge due to large drain uses and /or partial charges they used to run them flat to 'refresh' them back in the day (lay mans terms alert)

 

not the case with Lithium-Polymer.. these battery's LOVE partial charges.. they like to be topped up.. running them flat tends to make them eat them selves chemically. thus making the situation worse.. (iphone anyone?)...

Link to comment
Share on other sites

Same here. Still lasts as long as it should, so I believe it's an error on the software's end. If it was overcharging, the mouse would get very warm.

 

over charging Lithium-Polymer is also very bad.. they don't like cold.. they don't like hot lol.... i assume there is a cut off circuit in the mouse as trickle charging is also a no no which i suspect is why iCue never gets the 'i'm full' command

Edited by Zotty
Link to comment
Share on other sites

bad advice dude...... its a Rechargeable Lithium-Polymer Battery.

 

Ni-cads and the like used to to suffer 'memory' and to stop them holding poor charge due to large drain uses and /or partial charges they used to run them flat to 'refresh' them back in the day (lay mans terms alert)

 

not the case with Lithium-Polymer.. these battery's LOVE partial charges.. they like to be topped up.. running them flat tends to make them eat them selves chemically. thus making the situation worse.. (iphone anyone?)...

 

The ACPI-like monitor component may appreciate being recalibrated by doing this, however. :) Draining the battery may recalibrate the battery monitor's readings.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

::thread necromancy::

 

It's January of '19 and this issue does not yet seem to be addressed? I'm having the same issue regarding the "max value showing 75% in the iCUE dashboard". Can anyone on the Corsair team comment on (a) if this is being addressed and (b) when we can expect a fix?

Link to comment
Share on other sites

  • 4 months later...
How long would you expect it to take? Mine has been charging for 9 hours and it still only shows 1 green pulsing light.

 

Source of charging? Cuz something is wrong, either bad source or battery isn't keeping a charge, or the electronics isn't keeping an accurate track.

Link to comment
Share on other sites

  • 3 months later...

Hello,

 

i bought new (refurbished) Dark Core RGB SE, now i have it connected over USB cable for about 2 weeks constantly and iCUE is still just showing

 

Status / Battery CHARGING

 

It never shows something like Fully Charged, also it does not show any percentage, nowhere.

I discharged it meanwhile 2x via wireless connection (iCUE was showing red low battery level), then charging over cable for many days and the status is always CHARGING

 

I have only USB 3.1 ports on my laptop and the mouse is not hot.

I don't know how to check exact % status or any LED status.

I have latest iCUE version as well mouse firmware version.

 

I bought this mouse to use it always connected over USB cable.

To be used wirelessly occasionally when needed.

 

Is this constant CHARGING status normal - is this the already discussed "software bug"?

Can the always-on-cable usage destroy the battery sooner?

 

Thank you.

239826051_DarkCoreSE.thumb.png.3afe227610491099ad55dcc47d0bbc55.png

Link to comment
Share on other sites

Yes, while the mouse is connected to power, it always shows "Charging". It's an iCUE limitation. Also, once fully charged, it reports 75%. Another iCUE issue.

 

That's really weird.

Corsair Support wants to replace my mouse due to this.

Link to comment
Share on other sites

 Share

×
×
  • Create New...