Jump to content
Corsair Community

K95 RGB Marco Fix (When re-installs dont work)


FrostyOwl
 Share

Recommended Posts

Hi there,

 

I'm posting this in the event someone like me has tried everything to repair the macro functionality on their K95 RGB keyboard. Hopefully I can list some words people may use in their google searches;

 

Corsair Marcos not working

Marco Excecution Unavailable

Macro Excecution Stopped Working

Corsair Bus not working properly

Corsair Composite Virtual Input Device not installed

Corsair Composite Virtual Input Device not in Human Interface Devices

(Let me know if theres any I left out)

 

(Please note this only works for Windows 7 as far as I know, windows 10 may work)

 

At this point you should have tried reinstalling CUE, repairing the CUE software, deleting all profiles of the keyboard, multiple restarts in between and deleting all mentions of corsair in your registry.

 

This solution will apply to you if you DO NOT find "Corsair Composite Virtual Input Device" in your "Human Interface Devices" of your Device Manager. You will also notice under "System Devices" that "Corsair Bus" will have a yellow warning sign on it; right click into properties and under device status there should be a message that says

 

"an not verify the digital signature for the drivers required for this device. A recent change to hardware or software may have installed a file that is not properly signed, that is damaged or that might be malicious software from an unknown source. (Code 52)"

 

Now that we've established you definitely have this problem, you will have to download a Windows Hotfix. To be clear, there is nothing wrong with the keyboard or software itself, Windows (Windows 7 specifically) doesn't recognize the keyboard properly and basically stops the driver install of the software needed for the K95.

 

https://www.microsoft.com/en-us/download/details.aspx?id=46148

 

Here is the download link for the Hotfix (KB3033929) which repairs whatever authentication errors happened during driver installs. Restart your system and the marcos on your K95 should work!

 

Please comment if there's any mistakes, or if the issue still persists, then maybe people in the future might be able to find it.

 

Previous threads that may be helpful:

http://forum.corsair.com/v3/showthread.php?t=164900 (Toasted found the solution)

http://forum.corsair.com/v3/showthread.php?t=174188 (Mentions of the requirement of corsair bus and corsair composite virtual input device for marcos to work)

Edited by FrostyOwl
adding text
Link to comment
Share on other sites

  • 5 months later...

Frosty Owl, problem still exists.

 

Just purchased a K95 RGB Platinium keyboard and when I try and run the iCue file 3.9.93 I get an error that says "Installation error" "cannot read package".... I have that hotfix (KB3033929) installed and I am using Windows 7 64 bit system.

Help please?

 

CatsSands

Link to comment
Share on other sites

 Share

×
×
  • Create New...