Jump to content
Corsair Community

h100i not visible in latest Corsair Link


sddjd
 Share

Recommended Posts

Fan RPM's are ridiculously high as well.

 

Problem is, every post suggesting resolutions to the latest debacle that is the Corsair Link software is to look in Device Manager for Corsair USBXp Driver.

 

Problem is, NO SUCH DEVICE EXISTS there.

 

This is a working h100i v2 switched in from another pc with working (older probably being the reason) Corsair link software. Now I'm looking at fan speeds in the tens of thousands and the system is unaware of the h100i v2.

 

Removed, reinstalled, rebooted more times than I can count.

 

What is the issue with the latest software and how to get it to see my device? For all the slander against CAM I was certainly able to set that up on my other workstation with not one hitch.

 

Ready to switch camps after a LONG evening wasted trying to get this software to function.

 

Edit:

 

Stopping the service and the re-launching the software has the effect of correcting the crazy fan speeds, but still no h100i v2 or any device listed in the options window.

 

How does one force the installation of the usb driver (no unknown devices are present in DM)?

Edited by sddjd
Added info
Link to comment
Share on other sites

I was in the same boat as you. could not find the device, nothing would see it. fans stayed constant. every suggestion did not help.

 

for me it was becase of the spring windows 10 update. so I rolled that back and link worked properly again.

 

Start -> Setting -> Updates and security -> recovery -> go back to previous version of windows.

 

there is also an option to stop updates for 30 days, hopefully that will be enough time for corsair to fix this.

 

after that i reinstalled link and rebooted and it all started working again after that.

 

hope this helps you.

Link to comment
Share on other sites

 Share

×
×
  • Create New...