Jump to content
Corsair Community

K70 RGB Rapidfire connectivity problems?


cheezesizzle
 Share

Recommended Posts

Happy (or unhappy Saturday, for myself) to all!

 

I have a K70 Rapidfire, owned for about 2 months now.. Loved every second with it so far, until last night around 2am when my keyboard just magically disconnected from my PC.. So I did everything from a reset, to updating/reinstalling drivers, to changing USB ports. I am getting an error in Windows itself when I troubleshoot the device.am getting the "USB Composite Device is an older USB device and might not work with USB 3.0. I assured my keyboard was plugged into a 2.0 slot all along. So I'm a bit stumped here... We own a Mac in the household as well and it connected right into that.. no problems.. I would also like to mention, that when I plug the keyboard directly into my PC, that it lights up for around 2 seconds, then shuts off. I have found I do get some functionality, but the entire thing doesn't always respond. Any help or tips would be greatly appreciated!

 

Thank you all and bless up!

Link to comment
Share on other sites

  • Corsair Employees

Can you try resetting the keyboard? Unplug the keyboard, hold down the ESC key, then plug in the keyboard while still holding down the key for 30 seconds. Once you release the ECS key the keyboard itself should flash.

 

If that does not do anything I'd suggest to open a ticket on our support portal and a Technical support agent will be able to further assist you.

Link to comment
Share on other sites

 Share

×
×
  • Create New...