Jump to content
Corsair Community

Second keyboard after RMA'ing my first one, still has light flickering issue.


Zammin
 Share

Recommended Posts

I had to RMA my first K95 platinum because it had two issues:

 

- Failure to auto switch profiles when prompted by CUE (when launching games and such)

- Random lights under the keys flickering white every so often.

 

The replacement I got has fixed the issue with profile switching (actually it hasn't, see posts below), which was my primary concern, however the issue with random LEDs flickering white every so often remains. It's a small issue and I thought it might be an issue with CUE, so I waited to see if the next few updates to CUE would fix it. There have been about 3 updates to CUE since then, and I have even tried iCUE and the issue persists.

 

I have tried running the keyboard without CUE recently and the issue still occurs. Perhaps it's a firmware issue however it's worth noting I am on the latest firmware.

 

Is this a relatively small issue? yes. However when purchasing Corsair's top of the line and most expensive keyboard I would expect no glitches. Especially after having to RMA the first one. I live in Australia and these things cost $300 here!

 

If anyone reading this has experienced the same thing, please let me know.

 

If anyone from Corsair is reading this, please chime in and give my your thoughts or some ideas to trouble shoot this. I will not be contacting Corsair's tech support because every time I deal with them they are unhelpful and often ignore me. I seem to have better luck posting on the forum.

 

Perhaps this is also worth posting in the RMA section of the forum?

 

Let me know.

 

Thanks.

Edited by Zammin
Edited title due to additional issues
Link to comment
Share on other sites

Hi Zammin,

 

For the flickering, does it happen on different ports or different computers as well? Curious to here that it's still happening even after switching to another replacement unit.

 

Hi and thanks for the reply.

 

It does happen regardless of USB port, I don't really have another PC to test it on. It's unpredictable so I'd need to be using it on someone elses PC throughout the day to really test it. I have updated all my driver's though, and I'm not using a third party USB card or anything.

 

Check my threads and your logs from CUE for buffer write failures.

 

Hey there, I've had a look through the logs and couldn't see anything about dropped packets, I'll see if it says anything about buffer write errors. is there anything else I should be looking for? I'm on iCUE right now.

 

Yup, CUE issue, not hardware.

 

I'm not entirely convinced that it's CUE, as I mentioned it does it when CUE isn't running as well. Might be a firmware problem.

Edited by Zammin
Link to comment
Share on other sites

I had a look at my logs and there was only one of these:

 

"2018-05-16T13:58:21 I cue.dev: Buffer write, 1. failed. request timed out for K95 RGB PLATINUM"

 

Additionally, although not related to the keyboard it was followed by this:

 

"2018-05-17T07:53:15 I cue.dev: MouseMat LED colors change failed. req"uest timed out for MM800RGB"

 

If it helps, I can copy and paste the entire logs here. Let me know.

Edited by Zammin
Link to comment
Share on other sites

I can't believe this, additionally to this issue, after leaving my PC on overnight the profile switching problem is back. As soon as the keyboard was prompted to enter the profile set for Titanfall 2 all the lights froze just like my first one. So the original problem is back. I've had so many problems with Corsair peripherals it's driving me nuts... :(

 

I had to make the pictures below links because for some reason they were showing up as huge in this thread, but this is what my Titanfall 2 profile is supposed to look like, orange/yellow to match the Corsair MM800RGB mouse mat you can see in the background:

 

https://i.imgur.com/2TUU9rO.jpg

 

This is what it looked like when I launched Titanfall 2. Notice how the Corsair mouse mat has switched correctly but the keyboard is still on my default (red) profile?

 

https://i.imgur.com/T0XKqa4.jpg

 

The rainbow wave at the top is frozen as well. The only way to remedy this is to disconnect the keyboard and plug it back in.

 

I will post the contents of the log file below, can someone from Corsair please have a look and help me fix this.

 

I want to like my Corsair stuff so badly, I love the aesthetic and feel of all the peripherals I've owned but I've had nothing but trouble with them since day one. I've returned 2 Glaive mice and RMA'd one K95P only to have the same issues surface again. I have absolutely no such issues with any of my Razer or Steel Series stuff. I've spent $355 on this keyboard including the double shot PBT keycaps (which really should be included on the K95P in the first place) and I don't want to have to replace it..

 

Log File Contents: (the issue occurred at 17:35, suspect entries are in RED)

 

2018-05-16T12:23:35 I cue.dev: Opened device: "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-16T12:23:35 I cue.dev: Begin attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2018-05-16T12:23:35 I cue.dev: End attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2018-05-16T12:23:35 C dev.manifest: Cannot find path for manifest key (vid=1532, pid=5c)

2018-05-16T12:23:35 I cue.dev: Manifest for device (vid=1532, pid=5c) not found.

2018-05-16T12:23:35 I cue.dev: Failed to open device: (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col05#7&37ba9901&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-16T12:23:35 C dev.manifest: Cannot find path for manifest key (vid=b05, pid=1872)

2018-05-16T12:23:35 I cue.dev: Manifest for device (vid=b05, pid=1872) not found.

2018-05-16T12:23:35 C dev.manifest: Cannot find path for manifest key (vid=1038, pid=1724)

2018-05-16T12:23:35 I cue.dev: Manifest for device (vid=1038, pid=1724) not found.

2018-05-16T12:23:35 I cue.dev: Opened device: "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-16T12:23:35 I cue.dev: Begin attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2018-05-16T12:23:35 I cue.dev: End attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 1

2018-05-16T12:23:35 I cue.dev: Initializing "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d)

2018-05-16T12:23:35 C dev.manifest: Cannot find path for manifest key (vid=46d, pid=c52b)

2018-05-16T12:23:35 I cue.dev: Manifest for device (vid=46d, pid=c52b) not found.

2018-05-16T12:23:35 C dev.manifest: Cannot find path for manifest key (vid=1038, pid=1724)

2018-05-16T12:23:35 I cue.dev: Manifest for device (vid=1038, pid=1724) not found.

2018-05-16T12:23:35 C dev.manifest: Cannot find path for manifest key (vid=1038, pid=1724)

2018-05-16T12:23:35 I cue.dev: Manifest for device (vid=1038, pid=1724) not found.

2018-05-16T12:23:35 I cue.dev: Initialized true "MM800RGB" (vid=1b1c, pid=1b3b)

2018-05-16T12:23:35 I cue.lightings.player: Started lighting worker in 0x2b74

2018-05-16T12:23:35 I cue.dev: Device insertion processing complete for MM800RGB.

2018-05-16T12:23:35 I cue.dev: Initialized true "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d)

2018-05-16T12:23:35 I cue.lightings.player: Started lighting worker in 0x2b78

2018-05-16T12:23:35 I cue.dev: Device insertion processing complete for K95 RGB PLATINUM.

2018-05-16T12:23:36 C dev.manifest: Cannot find path for manifest key (vid=1b1c, pid=7)

2018-05-16T12:23:36 C dev.manifest: Cannot find path for manifest key (vid=1b1c, pid=1)

2018-05-16T12:23:36 C dev.manifest: Cannot find path for manifest key (vid=1b1c, pid=400)

2018-05-16T12:23:36 C dev.manifest: Cannot find path for manifest key (vid=1b1c, pid=2)

2018-05-16T12:23:36 C dev.manifest: Cannot find path for manifest key (vid=1b1c, pid=400)

2018-05-16T12:23:37 C cue.download.fw: Incorrect index contents: fw obj is empty "combined-image"

2018-05-16T12:23:37 I cue.download.fw: Incorrect index contents: condition for "image-priority" is empty

2018-05-16T12:23:37 C cue.download.fw: Incorrect index contents: fw obj is empty "combined-image"

2018-05-16T12:23:37 I cue.download.fw: Incorrect index contents: condition for "image-priority" is empty

2018-05-16T13:58:21 I cue.dev: Buffer write, 1. failed. request timed out for K95 RGB PLATINUM

2018-05-16T17:17:32 C dev.manifest: Cannot find path for manifest key (vid=9886, pid=1)

2018-05-16T17:17:32 I cue.dev: Manifest for device (vid=9886, pid=1) not found.

2018-05-17T07:53:15 I cue.dev: MouseMat LED colors change failed. request timed out for MM800RGB

2018-05-17T17:27:02 I cue.init.ui: Starting UI.

2018-05-17T17:27:02 W QObject::connect: invalid null parameter

2018-05-17T17:27:02 I cue.dev: Get profiles list failed. request timed out for K95 RGB PLATINUM

2018-05-17T17:27:02 I cue.dev: Get profiles list failed. Device: K95 RGB PLATINUM, Execution result = 0, result = 0, platform error code = 995.

2018-05-17T17:27:03 W MainWindow_QMLTYPE_463(0x1a925030) must be a top level window.

2018-05-17T17:27:03 W MainWindow_QMLTYPE_463(0x1a925030) must be a top level window.

2018-05-17T17:27:03 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:03 W qrc:/qml/ui/DevicesPanel.qml:87:4: QML Binding: Binding loop detected for property "value"

2018-05-17T17:27:03 W <Unknown File>: QML DelegateModel: Error creating delegate

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W DirectWrite: CreateFontFaceFromHDC() failed (Indicates an error in an input file such as a font file.) for QFontDef(Family="", pointsize=9, pixelsize=12, styleHint=5, weight=50, stretch=100, hintingPreference=0) LOGFONT("MS Sans Serif", lfWidth=0, lfHeight=-12) dpi=96

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W qml: Role 'decoration' is undefined

2018-05-17T17:27:15 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-05-17T17:27:15 W qml: Role 'decoration' is undefined

2018-05-17T17:27:15 W qrc:/qml/delegate/DeviceSettingsProperties.qml:510:18: Unable to assign null to QUrl

2018-05-17T17:27:15 W qrc:/qml/delegate/DeviceSettingsProperties.qml:510:18: Unable to assign null to QUrl

2018-05-17T17:27:15 W qrc:/qml/editor/MobileServerSettingsEditor.qml:55: TypeError: Cannot read property 'serverLocalIp' of null

2018-05-17T17:27:15 W qrc:/qml/editor/MobileServerSettingsEditor.qml:52: TypeError: Cannot read property 'connectionAllowed' of null

2018-05-17T17:27:15 W qrc:/qml/editor/MobileServerSettingsEditor.qml:61: TypeError: Cannot read property 'connectionAllowed' of null

2018-05-17T17:27:15 W qrc:/qml/editor/MobileServerSettingsEditor.qml:97: TypeError: Cannot read property 'connectionAllowed' of null

2018-05-17T17:27:15 W qrc:/qml/editor/MobileServerSettingsEditor.qml:131: TypeError: Cannot read property 'connectionAllowed' of null

2018-05-17T17:27:15 W <Unknown File>: QML DelegateModel: Error creating delegate

2018-05-17T17:27:20 C cue.download.fw: Incorrect index contents: fw obj is empty "combined-image"

2018-05-17T17:27:20 I cue.download.fw: Incorrect index contents: condition for "image-priority" is empty

2018-05-17T17:28:18 I cue.init.ui: Trimming cache.

2018-05-17T17:35:21 I cue.lightings.player: Stopped lighting worker in 0x2b78

2018-05-17T17:35:21 W cue.dev: Device "K95 RGB PLATINUM" worker thread has stopped

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col02#7&37ba9901&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col03#7&37ba9901&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_00#7&2d38952f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col01#7&37ba9901&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:27 I cue.dev: Marked as slow startup "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col05#7&37ba9901&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Opened device: "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col02#7&37ba9901&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Begin attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col02#7&37ba9901&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2018-05-17T17:35:28 I cue.dev: End attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col02#7&37ba9901&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2018-05-17T17:35:28 I cue.dev: Created new device "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d); ready: false

2018-05-17T17:35:28 I cue.dev: Opened device: "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col03#7&37ba9901&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Begin attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col03#7&37ba9901&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2018-05-17T17:35:28 I cue.dev: End attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col03#7&37ba9901&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2018-05-17T17:35:28 I cue.dev: Opened device: "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Begin attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2018-05-17T17:35:28 I cue.dev: End attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col04#7&37ba9901&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2018-05-17T17:35:28 I cue.dev: Opened device: "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Begin attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2018-05-17T17:35:28 I cue.dev: End attaching to "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_02#7&13e35b3f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 1

2018-05-17T17:35:28 I cue.dev: Initializing "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d)

2018-05-17T17:35:28 I cue.dev: Failed to open device: (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_00#7&2d38952f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Failed to open device: (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col01#7&37ba9901&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Failed to open device: (vid=1b1c, pid=1b2d) "\\\\?\\hid#vid_1b1c&pid_1b2d&mi_01&col05#7&37ba9901&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}"

2018-05-17T17:35:28 I cue.dev: Initialized true "K95 RGB PLATINUM" (vid=1b1c, pid=1b2d)

2018-05-17T17:35:28 I cue.lightings.player: Started lighting worker in 0x19bc

2018-05-17T17:35:28 I cue.dev: Device insertion processing complete for K95 RGB PLATINUM.

2018-05-17T17:35:28 C cue.download.fw: Incorrect index contents: fw obj is empty "combined-image"

2018-05-17T17:35:28 I cue.download.fw: Incorrect index contents: condition for "image-priority" is empty

Edited by Zammin
Link to comment
Share on other sites

Oh also I can confirm the profile switching/freezing issue has happened on 3 separate systems. When I had my first K95P I owned an older 4790k system, and before RMA'ing it I tested it overnight on another person's PC (7600k system) and the exact same thing occurred. Now I have an 8700k system and the same issues are occurring.

 

So to summarise, the LED flickering issue occurred on both my old and new system, and the profile switching/freezing issue occurred on 3 separate PC's altogether.

 

Corsair, please give me your thoughts. I'm thinking it may be a problem with your K95P firmware, but I'd be happy to be proven wrong.

Link to comment
Share on other sites

Keyboard profile froze again today when launching Titanfall 2. Found these in the log again:

 

2018-05-20T17:28:57 I cue.dev: Buffer write, 1. failed. request timed out for K95 RGB PLATINUM

2018-05-20T17:51:55 I cue.lightings.player: Stopped lighting worker in 0x327c

2018-05-20T17:51:55 W cue.dev: Device "K95 RGB PLATINUM" worker thread has stopped

 

I would really appreciate some assistance.

Link to comment
Share on other sites

I have the same problem. It's so annoying and i can't do nothing about it. With the new iCUE the flickering seems to be worse than the CUE2 because now even my Corsair Sabre RGB becan to flicker. I don't even know if i should buy their products anymore. Also my keyboard is a Rapidfire RGB (RMA'd 2 times) with the new light controller so it should not flicker but it does.
Link to comment
Share on other sites

I have the same problem. It's so annoying and i can't do nothing about it. With the new iCUE the flickering seems to be worse than the CUE2 because now even my Corsair Sabre RGB becan to flicker. I don't even know if i should buy their products anymore. Also my keyboard is a Rapidfire RGB (RMA'd 2 times) with the new light controller so it should not flicker but it does.

 

Thanks for chiming in. Do you experience the profile freezing issue as well or just the flickering?

Link to comment
Share on other sites

I am waiting on Corsair support to contact the CUE team about these issues, but I have had zero luck getting a response from any of the Corsair employees here on the forum.

 

I'm not really sure why they aren't chiming in. I don't know if they are the same people as technical support or a separate group, either way I'm hoping to get at least one of these issues resolved before this thread is buried and never seen again..

Link to comment
Share on other sites

  • 4 weeks later...

Just wanted to make a quick shout out to David and Brian at Tech Support who have been a huge help and made my RMA experience a smooth one. I've had mixed experiences in the past but these guys were great. They've replaced my keyboard for me and will be having a closer look at my old one for testing soon.

 

I've only had the new keyboard for a couple days so I can't say for sure whether it has any of the same issues yet, however if they do return I'll post here again.

Link to comment
Share on other sites

  • 11 months later...

So I bought a K55 a while ago and Im having similar issues with errors in the log. My system comes to a crawl when gaming with this keyboard. When I unplug it and use my older keyboard, everything goes back to normal. Took me 2 days to figure out it was the keyboard causing issues.

 

I get similar issues as this post: http://forum.corsair.com/forums/showpost.php?p=954994&postcount=7

 

My errors:

 

[\\KFX-PC]
...
00001153	613.31878662	[4948] 2019-05-25T13:50:11 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=3)
00001154	613.31890869	[4948] 2019-05-25T13:50:11 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=3)
...
00001815	1686.85266113	[4948] 2019-05-25T14:08:04 C cue.devices.manifest: Cannot find path for manifest key (vid=1532, pid=1f)
00001816	1686.85290527	[4948] 2019-05-25T14:08:04 I cue.devices: Manifest for device (vid=1532, pid=1f) not found.

 

My question is would I be able to RMA if i do not have receipt.

Link to comment
Share on other sites

So I bought a K55 a while ago and Im having similar issues with errors in the log. My system comes to a crawl when gaming with this keyboard. When I unplug it and use my older keyboard, everything goes back to normal. Took me 2 days to figure out it was the keyboard causing issues.

 

I get similar issues as this post: http://forum.corsair.com/forums/showpost.php?p=954994&postcount=7

 

My errors:

 

[\\KFX-PC]
...
00001153	613.31878662	[4948] 2019-05-25T13:50:11 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=3)
00001154	613.31890869	[4948] 2019-05-25T13:50:11 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=3)
...
00001815	1686.85266113	[4948] 2019-05-25T14:08:04 C cue.devices.manifest: Cannot find path for manifest key (vid=1532, pid=1f)
00001816	1686.85290527	[4948] 2019-05-25T14:08:04 I cue.devices: Manifest for device (vid=1532, pid=1f) not found.

 

My question is would I be able to RMA if i do not have receipt.

 

Technically you can RMA but they will consider the Manufactured date as a starting date of the warranty which could be an extra year or so depending how long the product was on the shelf.

 

Your best bet is to ask for a copy of your original receipt from the shop you bought it from or else be ready for the worst.

Link to comment
Share on other sites

 Share

×
×
  • Create New...