Jump to content
Corsair Community

How to Fix Blinking Fans


TLBradbury
 Share

Recommended Posts

Like many others, I too have had problems with my beautiful RGB fans (6 LL120s) flashing and blinking for no apparent reason. I immediately realized it couldn't be a hardware issue (6 fans suddenly flashing at the same time? I don't think so), so I started looking at the software chain.

 

If you look at the Device Manager under Universal Serial Bus controllers, you will see an item called 'Corsair USBXp Driver' (see attached image). Highlight it and select 'Uninstall Driver' either from the toolbar, or right-click (context) menu. Your lights should go out at this point.

 

Right-click on the USB Controllers item (actually any item will work) and select 'Scan for hardware changes'. This will re-install the driver, and you will notice your fan lighting is now working again!

 

Hope this helps folks who have been frustrated with this problem. I rather suspect a number of problems with RGB products are related to this driver. Now let's see it Corsair can figure out how to fix it!

 

Terry

1183690361_DeleteCorsairUSBXpDriver.JPG.1e1dd397937aadf1812b03c75510f605.JPG

Edited by TLBradbury
Additional info, typo
Link to comment
Share on other sites

Hi TLBRadbury, this sounds interestingly positive news.

Though question for me, after the process, have the blinkings re-occur?

For me the blinking is a bit erratic, and so far my temporary solution is to reorder the fans.

I have gone through the restart route, the corsair service route, individual isolation(to see if it's a hardware issue), brightness adjustment, and reinstallation of iCUE.

I will keep this one handy if and when mine happens again.

Hopefully this is indeed the solution...such beauty these fans are but damn frustrating.

Link to comment
Share on other sites

Good to se someone may have figured out the issue. I started getting this after the latest update to iCUE and firmware update to the Commander Pro; guessing the latter is just coincidence.

I switched back to Link and CUE but having seen this I'm back on iCUE again and hoping that after the next reboot I don't get the manic rainbow effect on my 6 LL120s.

Love it when it all works but when it doesn't it kills me when I think how much money I've spent on this kit.

Will look out for the rogue driver should it happen again.

Thanks for the post and efforts trying to track this down.

Link to comment
Share on other sites

one thing to note though,if yiu have an h100i v2,or probably any corsair aio,might get affected.

just for the heck of it i tried the process about the usb controller and after that my device manager was not able to recognize my aio. so had to uninstall reinstall icue.

Link to comment
Share on other sites

I have an 150i, but I don't think that will make much of a difference. What the folks at Corsair have to figure out is what's triggering the problem. It seems to me that it is some kind of activity or signal on the USB bus that is 'tripping' the Corsair driver, causing it to fail.

 

Just this morning I re-started the system and BANG! It happened again. Not too big a deal since I (now) know what to do, but this kit cost too much money (way over half of it to Corsair) to be failing on a stupid driver.

 

Unfortunately, it's been like this for years with Corsair -- great hardware, crap software. Since I rather suspect they farm out the code work, I think they need to find better contractors to figure it out. If it's all in-house, then heads need to roll.

Link to comment
Share on other sites

UniEizMan - you should not have to re-order the fans. Unless you are seeing a problem with one specific fan, the problem should be the same for all fans connected to the hub. If that is indeed what you are seeing, your problem may be different than what I am talking about. Good luck!
Link to comment
Share on other sites

Ok, quick update on my 'blinking fans'...anyone else seeing this? Separate post might be needed.

I don't see the USB entry under device manager so I can't take that action it turns out. :(:

I did manage to fix the flashing fans by forcing the firmware update on the Commander Pro but that lasted as long as the next reboot and since hasn't worked as a fix. :mad:

 

On top of that I opted a for a rebuild as Win 10 is so quick to install. I still have the same issue with nothing but the OS and iCue installed [updates etc aside]. :mad::mad:

 

When they start to flash and blink my fans are completely uncontrollable from a lighting point of view...would love to know what the hell is going on as this only happened after iCue was updated along with the firmware update for the CommPro.

 

 

Next thing is to try and roll back the version of iCUE and see if that works.

Link to comment
Share on other sites

Ok, quick update on my 'blinking fans'...anyone else seeing this? Separate post might be needed.

I don't see the USB entry under device manager so I can't take that action it turns out. :(:

I did manage to fix the flashing fans by forcing the firmware update on the Commander Pro but that lasted as long as the next reboot and since hasn't worked as a fix. :mad:

 

On top of that I opted a for a rebuild as Win 10 is so quick to install. I still have the same issue with nothing but the OS and iCue installed [updates etc aside]. :mad::mad:

 

When they start to flash and blink my fans are completely uncontrollable from a lighting point of view...would love to know what the hell is going on as this only happened after iCue was updated along with the firmware update for the CommPro.

 

 

Next thing is to try and roll back the version of iCUE and see if that works.

 

You need to turn off Windows fast boot. It cleared up my issue

Link to comment
Share on other sites

  • Corsair Employees

Hi guys,

 

Just wanted to leave an update here. This is a known issue that will certainly be corrected in a future update. Remember that we're still in Beta right now, but we're excited for when we're ready to have everyone convert. Can't wait to see you then!

 

For now, we're always happy to see any information you can offer about your systems so we can analyze these issues here.

Link to comment
Share on other sites

  • 2 years later...
Hi, I just made an account to reply to this message. It's now 2021 and there is still no fix on this issue! The flickering drives me mad!! I've literally given up on it at this point.
Link to comment
Share on other sites

  • 5 weeks later...
Can confirm. I have icue 465x RGB case with the H100i RGB platinum aio and repeatedly throughout the day the USB sound notification plays and all of the lights flicker and flash to the rainbow pattern for a few seconds. Seeing as this thread is years old, it does not give me much hope that it will be fixed anytime soon
Link to comment
Share on other sites

 Share

×
×
  • Create New...