Jump to content
Corsair Community

570x mirrored badge LED


Violents
 Share

Recommended Posts

Mine is not working properly. It only works on geen yellow and blue. I filed a ticket with support about a week ago and the only response i got was aaking me if i had it plugged in,and then silence. Any suggestions on what to do next?
Link to comment
Share on other sites

Mine is not working properly. It only works on geen yellow and blue. I filed a ticket with support about a week ago and the only response i got was aaking me if i had it plugged in,and then silence. Any suggestions on what to do next?

 

Is this the same one from Reddit?

 

 

 

 

Link to comment
Share on other sites

Yeah Zotty that's me. They can only do a full replacement so im stuck. I dont feel like tearing it apart and rebuilding and cable mgmt again for a led.

Is this the same one from Reddit?

 

 

 

Edited by Technobeard
fixed BBCODE
Link to comment
Share on other sites

Yeah Zotty that's me. They can only do a full replacement so im stuck. I dont feel like tearing it apart and rebuilding and cable mgmt again for a led.

 

 

Is this the same one from Reddit?

 

 

 

 

Dang. I get what you are saying bud.. I wouldnt have been keen either tbh.. Wonder if Corsair can let you know what sort of LED it is and you could maybe source one your self?... Not the solution you are after but as it stands.. the only one :(...

 

Sorry I couldnt help any further dude.

Link to comment
Share on other sites

 Share

×
×
  • Create New...