Jump to content
Corsair Community

Scimitar Pro RGB drops connection when gaming.


LawlSTi
 Share

Recommended Posts

This seems to only be happening while playing Rainbow Six Siege. While playing, my Scimitar Pro RGB will stop responding for a split second and the color profile will change to the default rainbow scheme. I will also lose my actions as they are setup under another profile. This means mid game, I will no longer be able to lean, go prone, etc, as my actions are not set up on the default profile.

 

I have moved over to iCUE, from the latest version of CUE, as the problem was happening with CUE as well, and the problem corrected itself, but only for a day. Now it is back to dropping connection mid game.

 

In the logs its saying "2018-05-03T20:33:35 I cue.dev: Mouse LED colors change failed. Device: Scimitar PRO RGB, Execution result = 0, result = 0, platform error code = 995."

 

My K70, Lighting Node Pro, and H100i V2 never seem to lose connection in iCUE. Its only this damn mouse. To make matters worse, whenever I alt-tab while in game to reset my Scimitar Pro RGB within the iCUE software, R6 freezes outright every time, forcing a task manger end task.

 

Here is my log. I am forced to revert to my Razer Naga MMO =( I want to play with my new Scimitar. Whats the deal?

2018-05-03T18-28-24.log

2018-05-03T18-30-26.log

2018-05-03T18-31-19.log

2018-05-03T20-35-22.log

Link to comment
Share on other sites

I have reverted back to CUE 2.23.40, via the stickied thread above. Still having Mouse LED colors change failed.

 

Has this issue really be going on now with Corsair for over 3 years, as some other threads suggest? How is that even remotely acceptable?

Link to comment
Share on other sites

No sir. So far I can only replicate it in Siege. I have tried Rocket League, FFXIV, Destiny 2, Overwatch, and Sea of Thieves. No luck. I am not sure if it has something to do with how Siege is a CPU intensive game. Even with a GTX 980 Ti I regularly hit 80% - 90% CPU load while in Siege. In fact, the entire reason I upgraded to your H100i V2 was because of the stock heat sink on my 4790k wasn’t cutting it and I was bluescreening on overheating. Your liquid cooler keeps me at a steady 48Ish degrees now while playing Siege now, so thank you for that! Edited by LawlSTi
Link to comment
Share on other sites

I have reverted back to CUE 2.23.40, via the stickied thread above. Still having Mouse LED colors change failed.

 

Has this issue really be going on now with Corsair for over 3 years, as some other threads suggest? How is that even remotely acceptable?

 

Because they have absolutely atrocious testing/customer support. They'll just repeat the same support manual BS while not working to fix the problem (we wouldn't want to spend any "unnecessary" money to ensure our peripherals work as intended, would we?)

Link to comment
Share on other sites

  • Corsair Employees
No sir. So far I can only replicate it in Siege. I have tried Rocket League, FFXIV, Destiny 2, Overwatch, and Sea of Thieves. No luck. I am not sure if it has something to do with how Siege is a CPU intensive game. Even with a GTX 980 Ti I regularly hit 80% - 90% CPU load while in Siege. In fact, the entire reason I upgraded to your H100i V2 was because of the stock heat sink on my 4790k wasn’t cutting it and I was bluescreening on overheating. Your liquid cooler keeps me at a steady 48Ish degrees now while playing Siege now, so thank you for that!

 

Hmm, interesting. I wonder if it's something with Siege that is causing issues with CUE? I'll pass this along to our validations so they can take a look.

Also, don't rule out if it's the Scimitar itself. If you can, get an exchange to see if it clears up.

Edited by Corsair Mint
more
Link to comment
Share on other sites

 Share

×
×
  • Create New...