Jump to content
Corsair Community

Corsair VOID Pro Not Charging


Recommended Posts

Hello, my Corsair VOID Pro Wireless headset has suddenly begun to refuse to charge. Everything about this situation is strange. When I plug it in, it seems to disconnect other USB ports on my computer. For instance, when plugged in next to the wireless receiver, it turns off the receiver and the mouse (which is plugged in in the back). When I plugged it into the back, it turned off the adjacent USB port used for my network adapter.


There has been a constant "red" light that signifies that it's on low battery, and the headset colors do not turn on. If I true to turn it on via the power button, turns on for 3ish seconds, and then goes back off. But the weirdest part is that even while its supposedly dead, I am still able to use it, it just gives me a beep telling me its on low battery every minute or so. I've tried uninstalling my USB ports and then restarting the computer, but the issue still occurs when I plug it in. I don't believe its in bootloader mode, as I wasn't able to find the Advera thing or whatever. I've also tried charging it on other computers, and that didn't work either. Please, I really want this headset fixed.


I've had it for over 2 years now, and this is the first time anything like this is happened. Thanks in advance! :)

Link to comment
Share on other sites

  • Create New...