Jump to content
Corsair Community

iCUE Monitoring Freeze


Galoona
 Share

Recommended Posts

Hi forum,

 

First ever post so it's inevitable I'll miss something but here we go...

 

So I installed iCUE 2 weeks ago and yesterday patched to latest firmware. The issue I'm having was present on both firmware versions I've used.

 

I run the iCUE dashboard on a second monitor to keep any eye on temps etc. and everything functions as expected until I start to play Battlefield 1 or 4. After 5 to 10 minutes of either game running, the monitoring within the iCUE dashboard freezes and the graphs flat-line at whatever the reading was when the crash occurred. From what I can tell, the fan RPMs also freeze at the RPM that was present when the problem occurred. The RGB strips connected to the Commander Pro also default to Rainbow. For confirmation, I have no other monitoring software running at the same time as iCUE.

 

The only way to resolve is to kill "Corsair.Service" in task manager. The service auto-reloads after termination and the dashboard monitoring springs back to life, the RGB strips revert back to my profile setting and I basically resume normal operation. However, if I alt-tab back to the game, after 5 to 10 minutes it freezes again and the situation repeats. If however, I quit the game to desktop, it continues to work fine until I launch the game at which point the issue reoccurs. Every time without fail.

 

Naturally I've tried to troubleshoot. E.g. I've tried to repeat when not gaming by running Prime95 stress test and there's no sign of the issue even after one hour. I've also tried uninstalling iCUE, reverting back to using a combination of Link and CUE2 and had absolutely no issues at all. So the problem appears to be with iCUE specifically. I also currently have my memory, GPU and CPU all running at stock speed to ensure I rule-out any side-affects of an OC.

 

As for my Corsair hardware it's as follows:

 

Commander Pro with 3 140 ML Pros (non-RGB) and 4 RGB Strips (the fans use GPU as sensor)

H115i AIO with 2 140 ML Pros (non-RGB) (the fans use liquid coolant temp as sensor)

Strafe RGB

M65 RBG

RM1000i

ST100 RGB

 

I've attached most recent Service Error log. I also tried to upload the Service Trace log but it failed and said there was a missing security token(?).

 

Any advice would be much appreciated as I would prefer to persevere with iCUE early access as opposed to going back to Link/CUE2. I've searched all threads in the hope that someone else has experienced the same but I'm starting to fear that it's unique to my set-up :(:

 

Thanks in advance

Service_Error.log

Link to comment
Share on other sites

Hi DevBiker - thanks for response.

 

Up at around 80% on BF1 and lower on BF4. Prime95 obviously pushes 100% but no sign of iCUE freezing when under the stress test.

 

Not exactly apples-to-apples (believe it or not). Prime95 runs on a lower priority thread - so it doesn't suck CPU cycles from user-mode applications. The games are running as normal priority threads.

 

It seems to be a thread scheduling issue.

Link to comment
Share on other sites

Yeah I'm a little out of my depth here...

 

Do you think it's unique to my rig or perhaps an issue with the software? I've never had any sort of CPU trouble before at both stock and OC. I'm not particularity task heavy but prior to using iCUE, I've ran the games, Link, CUE2, Afterburner and Realtemp (over kill I know!) concurrently without any issue or conflicts.

 

Got a feeling it's time to leave early access and head back to the Link/CUE2 combo...

Link to comment
Share on other sites

You reckon it could be patched out in a future update? I'm starting to get used to the routine of restarting the Corsair.Service each time so will ride it out for a while if there's a chance of a fix.

 

And thanks for taking the time to respond - it's reassuring to know that I'm not necessarily on my own with this one!!

Link to comment
Share on other sites

I've just come across this thread, as I just did a stress test to see how my new H15i would do.. icue just stops doing anything, and so the fan and pump speeds don't increase, so I cannot see what is happening during a stress test. Is that normal behavior?
Link to comment
Share on other sites

For the cooler, you can save the settings to the device - this way, your fan curve will be applied regardless of whether iCue is active or not.

To do this, select the cooler. Then, in the hamburger menu for "Profiles", select "Save Static Lighting, DPI, Performance to Device"

Link to comment
Share on other sites

  • 2 years later...

Hello,

This is my first post, but i have been strugling with this problem for a long time, but finally sorted it, and wanted to leave my comment.

 

So, I have a RM850i and a H115i Pro RGB on my system. After moving from Link to iCUE, I never been able to properly control H115i as well monitor the system from iCUE.

 

I have experimented a lot of solutions from the forum through time, but none seem to work for me.

 

But now seems I fixed it after a some trial and error. Let me detail:

 

- I had the RM850i and H115i connected to a internal NZXT usb hub, plus and bluethooth card also connected to the same hub. The hub was connected to the only usb available on the Crosshair VI hero.

- With this setting, I could not control or monitor from iCUE the powersupply nor the AIO (clean windows install and whatsoever).

 

So I started playing arround:

- Uninstalling iCUE (latest version) but maintaining the Corsair USBxp driver, enabled me to monitor both the powersupply and AIO cooler from HWinfo64.

- Installing iCUE (latest version), but uninstalling the USBxp driver, enabled be to monitor RM850i and system components from within iCUE without freezing (or as I read, flat lines), but the H115i was not detected by iCUE; the system detected it as a normal usb device (under the name H115i Platinum, which is not).

 

As the USBxp controls the AIO, I thought this was a software problem or some sort of conflict, specially with the bluetooth card.

 

So next, I removed from the NZXT hub each device, one by one (while mainting iCUE, USBxp, and disabling fast boot on the motherboard and Windows 10):

- Started by removing the bluetooth card (my suspect), rebooted: did not work.

- Then, I removed RM850i connector (leaving only the H115i connected to NZXT hub), rebooted and everything was working fine on H115i: lighting, performance settings and monitoring from within iCUE .

- Plugged againg the bluetooth, rebooted: everything was working also as expected.

 

With this config (H115i and bluetooth card connected to NZXT hub), I enabled fast boot, and still everything is fine so far.

 

Bottom line, seems that the culprit was the RM850i and some sort of interaction with USBxp driver when iCUE (and probably Corsair.Service) is running. The solution was simple to unplugg the usb from RM850i (loosing for now the ability to monitor it).

 

Sorry for the long post, but seemed a lot off people were facing this, and it might help.

 

Best

Link to comment
Share on other sites

 Share

×
×
  • Create New...