Jump to content
Corsair Community

Latest update to Corsair Link 4 Broken?


SkodaZek
 Share

Recommended Posts

Performed the latest update to Corsair link and since doing so (Brand new windows install as of yesterday, as a fyi) the fan control seems to go wonky at times.

 

Was playing Assassins Creed Origins and my system crashed because my Core i7-6850k (Standard Clocks) was running at 110c (Cooled via Corsair H115i AIO). I started to watch my cpu temps close after that. Alas what seems to be occurring is Corsair Link seems to at random lock both my Radiator fans at 340rpm (Regardless of setting). If you open CL4 and try and manually change fan profile it will not work, you have to completely restart Corsair Link to get proper fan control back.

 

This has occurred several times for me since updating to the latest CL4 yesterday after installing new Windows 10 x64 Pro (Updated with latest drivers for all devices and all bios updates for board and video cards).

Link to comment
Share on other sites

That sounds like a driver crash - the driver dies and fails to report new data.

 

I see that you have EVGA GPUs. Are you running EVGA XOC?

 

That said, the cooler should run the fan curve and prevent you from hitting this temperature. Is your CPU overclocked? What is the vCore?

Link to comment
Share on other sites

I use MSI Afterburner rather than Precision XOC. CPU is not overclocked (due to the fact that my AX1200i did not have a 4 pin addon cpu power connector cable and only had the 6 pin. Both required by motherboard to overclock cpu).

 

Anyhow I uninstalled Corsair Link 4, cleared registry and all configuration files and installed fresh issue seems to have resolved itself after performing the reinstall.

Link to comment
Share on other sites

 Share

×
×
  • Create New...