Jump to content
Corsair Community

A7N8X Deluxe: Do I have bad memory?


Recommended Posts

The Setting:

Setup built 6/2003

MB rev is 2.0, BIOS (never flashed; 1003)

2x256 MB Corsair Value Select PC2700 (model VS256MB333) in DIMM Slots 1 and 3

Sapphire Radeon 9500

2 X WD 120G HD

Nec ND-3500a


350W Antec PSU



My BIOS setting for the CPU is normal 11X133 (All Auto), and for memory I've been


running with Memeory Settings "By SPD", which yielded 166MHz for frequency and 7, 3, 3, 2.5 for the other timings (in that order).


The DDR Ref. voltage was always at default 2.6V.


No overclocking at all at this point.


The problem:

For quite some time now, I've often gotten, '..checksum failure: probable memory fault.' errors from Quickpar when repairing (always large, i.e. >2GB size) rar archives.


Probably about 95% of the "incompletes" of an archive will be repaired, but the last block or two will give that error, and I must hit the repair button on Quickpar once again to complete the repair for the archive.


I saw several mentions on the Quickpar forums that this is quite likely an indication of bad memory, and I've always meant to run a memory test, but never did until now.


Using Goldmem507 with the normal setting (8,16 and 32 bit testing), after about 11 minutes I got 6 or so errors (some 8 bit, some 16 and some 32 bit), repeatable at (I'd

swear) the same point everytime I run that test.


Running the quick test (only 32 bit testing) yields no errors at all.


I then tested each stick individually in DIMM Slot 1, using the normal setting, and each stick passed completely (one full loop taking about 3 or so hours). This makes me think

the memory isn't performing properly in dual channel mode.


As a further test, I switched the DIMMS and ran the test, expecting that I would not get the memory erros at around 11 minutes in, but somewhere towards the end of the testing.


I didn't get errors at 11 minutes, but got one (1) at about 68% (maybe 2 hours) of the way through the test. Shortly after that point I aborted that test rather then waiting until the end.


I thought I'd read some posts about running memory at a Memory Timing of 100% for better stability, so I tried switching the Memory Timings from "By SPD" to "Auto". This resulted in the Memory Frequency displaying "Auto" in the BIOS page (which POSTs as 133 Mhz on POST), and timings of 6, 3, 3, 2.5T.


Running the test under these conditions yielded no errors at all.


So I wonder, are the errors I have been getting indicative of bad memory? Or should I not be running memory at 166Mhz whilst the CPU FSB is set to 133 MHz? Although I assumed that warning only applied to overclockers..


After speaking with a Corsair tech rep, he had me do the following.


First I flashed to the latest official 1008 bios, then he had me set the BIOS settings as follows:

System Performance: User Defined

FSB 133 and multiplier 11


Memory Frequency: 125%

Memory timings in order: 8, 3, 3, 2.5T

DDR Ref. Voltage: 2.7


Well with those settings, and the memory sticks back in the config which previously gave me erros at about 11 minutes, I ran Goldmem again.


(As an aside, I now see on POST, displayed after the memory frequency, the phrase "dual channel mode", which I don't recall seeing previously.)


Well, no memory erros at 11 minutes, and I thought all was well, but at 14:43 (16%), I got one (1) 8 bit error. Shortly after this I aborted testing and decided to try out

Memtest86+ (http://www.memtest.org).


I've now run through several passes of Memtest86+ using the standard (default) config, and no errors.


Should I change some setting on Memtest86+ to make it perform a "more rigourous" test?


Should I use the "other" Memtest86 (http://www.memtest86.com)?


So, again, is it my memory? My BIOS settings? A problem with Goldmem?


Any advice much appreciated.



Link to comment
Share on other sites

Please use http://www.memtest.org and test the modules one at a time and lets make sure one is not failing and please let the test run for 3-5 passes.
Let's call the memory Stick A and Stick B.


Testing in dual channel mode, memory in slots 1 and 3 (A and B in either slot), memtest86+ v.150 gives errors on Test 6 (Moving Inversions, 32 bit) on the 1st pass.


Testing each module separately, memtest says Stick B gives erros on Test 6, sometimes on Pass 1, and on other test runs it takes several Passes before it manifests an error-- but it always does.


Stick A doesn't appear to give errors..

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...