Jump to content
Corsair Community

Lighting node pro not detected?


Recommended Posts

Hi all, first post.


So 2 days ago when I finished my build and start it up. I have 6 fans (Corsair LL) installed and all 6 of them light up INITIALLY.


But next before I could even get to windows screen, 5 fans LED went out. So I went to corsair iCue and saw the lighting node pro and there is no fans.


I re-install iCue and the lighting pro is not even there!

Also, I couldn't even finish the download of the iCue software afterward.


My motherboard is Asus Formula X.

I tried installing an NZXT usb internal hub and try all the ports, swapping sata cable, lighting node pro and it still does NOT work..


But what's weird is that on both of the lighting node pro I've tried. Whichever fan is connected to port 1 will light up.








Edit : I'm also using a PWM fan hub if anything. I also use NZXT Hue + and Cam


Edit 2 : Newest version iCue is what I'm having trouble with. Another thing I forgot was I tried unplugging the usb port from the Hub that came with the 3 pack of LL 120 while the pc is running and I heard a "Window sound alert." Maybe this device is hidden somewhere and Corsair iCue couldn't detected?


EDIT 3 : Okay... I feel pretty mad right now.. So if anyone else have this issue, Uninstall the newest version of Corsair link and download Corsair Link Software Update Version!!!!!!

Edited by Hecarus
Link to comment
Share on other sites

To install the latest iCue, you may need to clear out all the files from the earlier installation.


To do these, delete everything in %ProgramData%\Corsair\Cue and %AppData%\Corsair\Cue.


If you are running iCue, you have to run Link 4.9.6 or later. Otherwise, they will conflict with each other.

Link to comment
Share on other sites

  • Create New...