Jump to content
Corsair Community

K95 and M65 Pro issues with CUE software.


Zyeox
 Share

Recommended Posts

No matter what I do this software works for 5 mins then stops. I have no clue what is going on. I have the K95 and the M65 Pro. All worked fine for a few weeks then the software updated and I have been having all kinds of problems. I setup my profile and it will work as I stated for 5 mins then it wont. For example I set the G1 key to open web browser. It shows that it is setup in CUE and it worked fine and nothing has changed and now it will not open up web browser. I tried to make it again and same problem. Works then it stops.

 

Now on to the M65 I setup my DPI and all of sudden I can not switch between DPI setting with the arrow buttons. I uninstalled reinstalled, I even downloaded the latest version same problem. Only thing that seems to work is that the colors on the keyboard and mouse are working just fine and seems to keep the settings I put in place.

 

I love this keyboard and mouse but this software is really frustrating to get it to work. Also I changed usb ports as well.

 

Windows 10

 

Thanks

Link to comment
Share on other sites

If you're on CUE 2.24.35, there's a bug with that version of CUE that's causing your issues. Try using a different version, or download iCUE from the Corsair website. iCUE is essentially the next generation of CUE or CUE 3.1.xxx
Link to comment
Share on other sites

I am having the exact same issues with a brand new k95 RGB Platinum keyboard and a brand new M65 Pro Mouse. I have to repair the software every 10 min to get the "extra features" to work on both the mouse and keyboard.

 

Were you able to fix this issue?

 

 

EDIT: Nvm, I actually was able to correct the issue by downgrading to a lower version of CUE.

Edited by KhaoticOne
Link to comment
Share on other sites

 Share

×
×
  • Create New...