Jump to content
Corsair Community

Corsair Dark Core Quality Issues


Harag
 Share

Recommended Posts

I picked up a Corsair Dark Core RGB Mouse. It has some serious quality issues. The first of the problems i experience are with Corsair CUE button assignments randomly not working mid game play. I have to alt-tab out of the game, close corsair CUE and reopen it to get my custom buttons/macros to work. The second of my problems are with the hardware itself. The paint on the "sniper" button is flaking off, i've only had the mouse a few weeks. Compound this with similar software issues when using my Corsair Scimitar and I start to develop a feeling that the design effort going in behind these products is lacking. The Scimitar itself is excellent hardware wise but corsair CUE is an absolute joke, full of bugs and issues.

 

I used to swear by corsair products (I own virtually the entire range of peripherals from Multiple K70s to the M65/Scimitar/Dark Core/ ST100/ RGB Mouse pad etc) Now I feel like maybe my loyalty is a bit misplaced. My Logitech products still work flawlessly. I have dropped thousands on peripherals from Corsair, I can honestly say I won't be buying another.

 

I am a bit of a peripheral nut, I basically collect them but there is no point in buying a product that cant even withstand the 4 - 6 months turn around cycle I go through with peripherals.

 

Please Corsair STEP UP YOUR GAME.

Link to comment
Share on other sites

Button assignments not working may be attributed to a bugged version of CUE you have, 2.24.

 

Corsair James posted Beta Build 2.24.48 on the Corsair Forums that fixed these issues:

http://forum.corsair.com/v3/showpost.php?p=946245&postcount=13

 

There's also the new iCUE, version 3.1.131, available in the Downloads section on Corsair's website. Basically Corsair Utility Engine and Corsair LINK in one software package if you want to try this out.

 

http://downloads.corsair.com/download?item=Files/CUE/CorsairUtilityEngineSetup_3.1.131_release.msi

Link to comment
Share on other sites

Button assignments not working may be attributed to a bugged version of CUE you have, 2.24.

 

Corsair James posted Beta Build 2.24.48 on the Corsair Forums that fixed these issues:

http://forum.corsair.com/v3/showpost.php?p=946245&postcount=13

 

There's also the new iCUE, version 3.1.131, available in the Downloads section on Corsair's website. Basically Corsair Utility Engine and Corsair LINK in one software package if you want to try this out.

 

http://downloads.corsair.com/download?item=Files/CUE/CorsairUtilityEngineSetup_3.1.131_release.msi

 

Appreciate the response but this is over multiple versions for the Scimitar and i have tried 2 versions for my Dark Core. Saddly this has been going on a long time and i just dont think Corsair does enough to rectify the issues, or actively try to prevent them in the first place.

Link to comment
Share on other sites

@Harag: OK, I have to ask, what the heck are you doing to your mouse that's flaking the paint off of the sniper button?? I've had mine for a month, and it still looks brand new. Is your sweat that corrosive?

 

I have a Logitech G700 that I've had since the product came out (2010) and it's still in great shape. I decided to try the Dark Core because I liked the button layout, and I needed higher DPI for my 4K setup. Plus I love the double wing grip; didn't think I would, but I find it very comfortable.

 

Just wondering what is going on with your apparent hardware attrition going on there?

Link to comment
Share on other sites

@Harag: OK, I have to ask, what the heck are you doing to your mouse that's flaking the paint off of the sniper button?? I've had mine for a month, and it still looks brand new. Is your sweat that corrosive?

 

I have a Logitech G700 that I've had since the product came out (2010) and it's still in great shape. I decided to try the Dark Core because I liked the button layout, and I needed higher DPI for my 4K setup. Plus I love the double wing grip; didn't think I would, but I find it very comfortable.

 

Just wondering what is going on with your apparent hardware attrition going on there?

 

The paint is flaking off of the top side of the button, not actually an area my thumb makes any contact with. Just a simply poor quality product.

Link to comment
Share on other sites

The paint is flaking off of the top side of the button, not actually an area my thumb makes any contact with. Just a simply poor quality product.

 

Is the top of the sniper button touching the above surface? It does not on mine.

Link to comment
Share on other sites

  • 6 months later...
 Share

×
×
  • Create New...