Jump to content
Corsair Community

CUE Lighting Bug


Recommended Posts

Hello,

I've been experiencing some problems with CUE in conjunction with my K95 Platinum and have been unable to find a concrete solution. I would like to know if anyone can help me.

 

Let me preface this post by saying that I have already talked to Corsair Support and they have been unable to provide a resolution.

 

When using CUE, after a random amount of time, random backlights on my K95 Platinum will either change colour or turn off. Sometimes only one key turns white or off, other times whole strings of alternating keys, such as the G2, G4 and G6 keys, etc.

There is no consistent timing between when the keys are affected. I have had it happen within 5 minutes of opening CUE and I've had it happen after CUE was running for over 24 hours. When looking at the lighting effects within the CUE interface, it will still show all the keys as correctly lit, despite the fact that the actual lights display something different.

 

Now, some may say that the problem is a defective keyboard, however I know this not to be the case. The issue only occurs when CUE is running. As soon as CUE is closed and the keyboard is using a hardware profile, the issue is solved. It only ever happens when using software to control the keyboard.

 

So far, every version of CUE I have installed in the past month or so has this issue. The earliest version I have attempted to use is 2.16.87 and the latest is iCUE 3.1.131. I know that iCUE is an early access program and may have bugs of its own, but that does not explain why every version of CUE I use is affected.

 

I had this same issue about a year ago when I first got my K95 Platinum. At that point, Corsair Support had me send it back and they sent me a new one. However, because it was a software issue, the replacement keyboard was still affected and the process essentially wasted about $75 AUD on shipping. CUE was later updated and the problem was resolved until now.

 

I am really at a loss for what to do. Corsair Support walked me through a complete uninstallation, deleting the Corsair folders in AppData and using CCleaner to remove the leftover registry files but this has had no effect. They also got me to hard reset and manually replace my keyboard firmware, but this has also been fruitless.

 

Is there anyone else facing a similar issue who can help? Is this a known bug that will be fixed soon? I really want some answers because this issue is getting on my nerves and nothing short of keeping CUE closed seem to have any effect.

 

Thanks,

slizer.

Edited by slizerbladez
Link to comment
Share on other sites

  • Corsair Employees

Try updating or force updating the firmware of your K95 Platinum.

 

You can also attempt a soft-reset which can be done by unplugging the K95, holding ESC down, plug in the K95 while holding ESC, then release ESC. K95 should flash briefly and in theory should be right as rain again.

Link to comment
Share on other sites

  • Corsair Employees
Thanks for replying. Unfortunately I've already attempted forcing the firmware to update to no avail. Soft-resetting has the same effect as closing CUE and re-opening it - a temporary fix. The problem seems to lie elsewhere.

 

Worth a shot and just wanted to double check. You mentioned you're trying this on iCUE and experienced this with it as well? Can you export a log for us to take a look at? You can find this in "Settings" and there'll be an export option as well. I'll check in with our software team tomorrow to see if they may have further insight.

Link to comment
Share on other sites

I have attached the exported log files. Additionally, here is what the CUE interface shows when the issue occurs: link; and this is what the keyboard actually looks like (affected keys marked in red): link.

Worth noting is the affected keys change every time the issue happens. Occasionally it's only one key and other times there are many.

CUElogs.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...