Jump to content
Corsair Community

Probleme mit iCUE, Corsair Link und dem HX850i


Chessfreak
 Share

Recommended Posts

Hallo zusammen,

 

wo fang ich an...

 

Anfang Dezember 2017 hab ich mir diverse Hardware gekauft, unter anderem ein Corsair HX850i Netzteil und die K95 RGB Platinum Tastatur.

 

Bin mit beiden prinzipiell sehr zufrieden, gäbe es da nicht den Fall, dass die Corsair Link Software gelegentlich alle USB-Geräte lahmgelegt hat (durch Ereignisanzaige herausgefunden), ein harter Neustart wurde da nötig.

Da auch Updates der Software nicht geholfen haben, habe ich das Problem einfach "umgangen", indem ich die Corsair Link Software deinstalliert habe, die Probleme sind dadurch nicht mehr aufgetreten. Die Daten des Netzteils können immer noch mit Tools wie HWiNFO64 ausgelesen werden. Die CUE Software machte derweil keine Probleme.

 

 

Jetzt kommt iCUE ins Spiel...

 

Durch die Installation von iCUE kam Corsair Link wieder auf den Rechner (in iCUE integriert) und erneut gab es Probleme, das Error Log ist voll mit Fehlern wie bspw.:

 

Datum- und Zeitstempel | Zahl | Rechnername | 3.1.0.29 | PowerSupplyUnitHidDevice | ->

System.IO.FileNotFoundException: Die angegebene Datei konnte nicht gefunden werden.

bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

bei System.IO.FileStream.WriteCore(Byte[] buffer, Int32 offset, Int32 count)

bei System.IO.FileStream.FlushWrite(Boolean calledFromFinalizer)

bei System.IO.FileStream.Read(Byte[] array, Int32 offset, Int32 count)

bei HumanInterfaceDevice.HidDevice.<>c__DisplayClass1.<Read>b__0()

bei HumanInterfaceDevice.TimingOutThreadRunner.<>c__DisplayClass1.<Start>b__0()

 

und (wenn der "Absturz" passiert):

 

Datum- und Zeitstempel | Zahl | Rechnername | 3.1.0.29 | PowerSupplyUnitHidDevice | ->

System.IO.IOException: Der E/A-Vorgang funktioniert nicht. Die Datei ist möglicherweise zu lang oder der Handle wurde nicht geöffnet, um synchrone E/A-Vorgänge zu unterstützen.

bei System.IO.FileStream.WriteCore(Byte[] buffer, Int32 offset, Int32 count)

bei System.IO.FileStream.FlushWrite(Boolean calledFromFinalizer)

bei System.IO.FileStream.Read(Byte[] array, Int32 offset, Int32 count)

bei HumanInterfaceDevice.HidDevice.<>c__DisplayClass1.<Read>b__0()

bei HumanInterfaceDevice.TimingOutThreadRunner.<>c__DisplayClass1.<Start>b__0()

 

und

 

Datum- und Zeitstempel | Zahl | Rechnername | 3.1.0.29 | CommandStateMachine | The command 0xFE got System.TimeoutException

System.TimeoutException: Timeout für den Vorgang wurde überschritten.

bei HumanInterfaceDevice.TimingOutThreadRunner.Start(Action action, TimeSpan timeout, ILog logger)

bei HumanInterfaceDevice.HidDevice.Read()

bei HumanInterfaceDevice.HidDevice.GetInputReportAsync(Byte reportId)

bei CorsairLink4.Module.HidDevices.Core.CommandStateMachine.<MoveNext>d__3.MoveNext()

 

 

Die bislang 3 "Abstürze" (in 2 Tagen, bzw seit Veröffentlichung von iCUE) hatten zur Folge, dass die Corsair Tastatur nicht mehr erkannt wurde, meine Logitech Maus ging noch, konnte also den Rechner normal neustarten.

Da es mich aber trotzdem nervt (es ist immer ein Neustart nötig, wenn der Fehler auftritt), habe ich jetzt kurzerhand die USB-Verbindung des Netzteils gekappt. Seitdem kamen außer Initialisierungsfehler der Art

 

Datum- und Zeitstempel | Zahl | Rechnername | 3.1.0.29 | PowerSupplyUnitHidDevice | Cannot open device CorsairLink4.Module.HidDevices.PowerSupplyUnits.PowerSupplyUnitHidDevice

 

keine weiteren Fehler im Log an, auch das Trace Log zeigt keine Fehler mehr.

 

 

Ist Corsair Link fehlerbehaftet? Hat mein Netzteil einen technischen Defekt?

 

Ohne Corsair Link funktioniert das Netzteil ja einwandfrei, auch die aktuellen Spannungs- und Leistungswerte lassen sich digital auslesen.

 

Leider ist einfaches Downgrade von iCUE auf CUE nicht möglich, mein Fehler, ich hätte ja alle CUE-Profile sichern können vor dem Update.

 

Wenn die Error/Trace Logs gewünscht werden, kann ich diese anhängen.

Beide zusammen haben insgesamt eine Größe von 85MB, alle enthaltenen Fehlermeldungen (grob überflogen) haben mit dem Netzteil oder mit Corsair Link zu tun.

 

Ich hoffe, das Problem ist softwareseitig behebbar, ich würde ungern (temporär) auf meinen Rechner verzichten müssen.

 

 

Mit freundlichen Grüßen

Chessfreak

 

 

PS.: Ich hätte den Post auch ins englische Forum geschrieben, aber ich dachte mir, bevor jemand von den deutschen Teilen der Fehlermeldungen verwirrt wird, schreib ich lieber ins deutsche Forum.

 

Edit: Logs als Anhang hinzugefügt.

Service logs.zip

Edited by Chessfreak
Link to comment
Share on other sites

Logs sind im Startpost jetzt angehängt.

 

Musste die Logs in eine zip-Datei packen, da sie mit jeweils ca. 50MB für das Forum zu groß sind.

Seitdem ich das USB-Kabel vom Netzteil getrennt habe, gab es bis auf die Meldung, dass das Netzteil nicht initialisiert werden konnte, keine neuen Einträge im Errorlog, beide Logs sind vom aktuellsten Stand.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...