Jump to content
Corsair Community

Corsair Glaive scroll wheel malfunctioned


xPubHD
 Share

Recommended Posts

Hey,

 

Today I got home and I went on my computer just to realize that the scroll wheel on my Corsair Glaive isn't working.

I did not understand why and I have not seen any other people having this problem on the Corsair Forum based on the Google searches that I've done.

 

It first started off with that it was like some kind of force not letting it too scroll, so it would go up but down again and the same thing with it going down and then up. Then it started to really act up by just flipping to the other side of the site when scrolling.

 

When checking my Windows mouse settings I had 3 lines per scroll which I remember always having. Then after that, I put it on one page then reverted it and it worked.

After a while it stopped working completely, really weird. So now my scroll wheel isn't working at all.

 

I have tried restarting my computer, forcing update, clearing onboard memory, messing around with some settings to see if it works but then ended up reverting it back. Everything is up to date and I am currently running my computer on Windows 7.

 

Thanks.

Link to comment
Share on other sites

  • 2 months later...

I have a similar issue with my Glaive that my Sabre never had.

 

Within the first few months, my Glaive's left button started to have an issue where clicks didn't register because the button wasn't coming up with enough force.

A bit later, my scroll wheel started to have an issue as well. If I apply only a little pressure on the wheel, it moves but doesn't make the clicks it's supposed to so that scrolling doesn't work.

 

I thought the Glaive was gonna be a great mouse for at least 2 or 3 years but I guess that its quality is gonna prevent me from using it for that long. My sabre works fine still and compressed air doesn't help.

Link to comment
Share on other sites

  • 1 year later...
If I apply only a little pressure on the wheel, it moves but doesn't make the clicks it's supposed to so that scrolling doesn't work.

 

I have the Corsair Glave too and stumbled across this thread from google.

 

I have the exact same issue as you: if you scroll slow, it doesn't register while the wheel is moving.

 

If you look closer, you can see when you scroll the rubber wheel slowly, that it slides over the plastic wheel itself like it doesn't have the grip, so it doesn't move the silver wheel part, so it doesn't register any movement.

 

It's like the rubber on a tire moving while the rim stays still. Might put a touch of glue on the side to keep it attached.

Link to comment
Share on other sites

  • 11 months later...
 Share

×
×
  • Create New...