Jump to content
Corsair Community

Corsair Utility Engine With K95 Platinum + Corsair VOID RGB Wireless + Corsair M65Pro


Semper
 Share

Recommended Posts

Hi there I dont know why but I recently updated keyboard to the stylish corsair k95 platinum and noticed there was a new update at the same time for the CUE software...

 

I am a streamer and demand the best of the best and since I am a corsair lover when it comes to the style of hardware I am very upset that the level of care they take in the products don't really move with the software...

 

I dont know if its just me but I notice that the software some how switches its self off so to speak.....

 

For example the software is always running in the background and when I load it the profile is still set but for some strange reason all the functions I have set my mouse to doesn't work.... this happen's regularly and normally a quit of the software and reboot would normally fix this for a few days...

 

Now I cant even get half way through a game on PUBG and its somehow turns itself dormant and this is a HUGE problem for me as my BR tactics mean I am very mouse dependant... I have searched high and low for a fix but have not came across one yet.... I have thus far uninstalled and re-installed cue and also forced all firmwire updates on the products that I have any help to get this working again would be appreciated thanks

Link to comment
Share on other sites

I just seen another post where the K95 Platinum sound wheel makes everything go pear shaped I tested and it cuts my mouse going to revert back to the software that the Corsair Support suggest to untill this issue is fixed I will keep you updated!!!
Link to comment
Share on other sites

I would like to report the issue has been resolved what I did was uninstalled CUE and re-installed the version of CUE that was recommended in another post with instead of linking I will copy and paste the users post below hope this helps anyone that has encountered this problem I am just shocked how it disabled my mouse functions but after some testing its all good :)

 

 

Corsair CJ wrote

We're aware of an issue that has appeared in a recent build of CUE that can result in macros and other actions being broken. Here's a build that should resolve this for anyone effected: https://www.dropbox.com/s/9wxvd9t3dl...lease.msi?dl=0

 

This is to be considered a beta build since it hasn't gone through our usual validation process.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I have the exact same setup and also the same issue. Very annoying. Unfortunately the link to the beta is no longer working. Is there any view on when this update will be released or could I get a copy of this beta version.

 

Many Thanks

 

Edwin

Link to comment
Share on other sites

  • Corsair Employees
Hi, I have the exact same setup and also the same issue. Very annoying. Unfortunately the link to the beta is no longer working. Is there any view on when this update will be released or could I get a copy of this beta version.

 

Many Thanks

 

Edwin

 

Hey Edwin, the link should still work. But just in case I was using a link that no longer is active, try this one: https://www.dropbox.com/s/9wxvd9t3dlhyvkr/CorsairUtilityEngineSetup_2.24.48_release.msi?dl=0

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...