Jump to content
Corsair Community

scimitar side buttons are not working after binding them


Hologenz
 Share

Recommended Posts

so i just recently did a full windows restore and installed all the basic software. i have a corsair k70 rgb keyboard and corsair scimitar rgb. i made a profile and started binding all my keys to side buttons with numbers 1-0, after i make them the mouse does not respond to any of the keys i bound them. the corsair cue says all the keys are bound but they dont work at all. i have made new profiles, reinstalled the software done resets but it still the side buttons on the mouse dont work.

 

1 time yesterday it worked. i made a profile with lightings, binds and all, then all of a sudden after like 4 hours or so the mouse side buttons stopped working and the lights on the mouse and keyboard reset to default rainbow spiral, but the cue software said it was still all keys and buttons are still bound, but the lighting settings changed back to default rainbow spiral.

 

i dont know what else to do the program will just not work for the mouse.

Link to comment
Share on other sites

im also having the same problems.

 

it started after the latest update.

 

It normaly happends after i start up a game and the side buttons will just stop working.

 

so far the buttons have started working again after shuting down the CUE and starting it again WITH THE GAME RUNNING and it works untill i quit the game and try to launch it again after the launch they stop working again or if i try to launch any other game.

 

personally i have had a very bad experiance with the CUE over all.

everything about it is just very unclear.

Edited by FancyCobra
Link to comment
Share on other sites

resting the cue software while having a game on and running did fix the problem but after a while it stopped working if i alt tab or leave it for a while.

 

im running the latest cue version 2.24.35 like you FancyConbra i might have the same problem as you.

Link to comment
Share on other sites

I'm returning my Scimitar pro to amazon as it isn't fit for purpose. I have programmed it numerious times but it always fails to last more than a couple of reboots before the side buttons stop working. Ive lost count of the number of reinstalling of the cue software and reprogramming of buttons I have done. Just got to sell my K70 rgb rapidfire then I'm going over to Razer.
Link to comment
Share on other sites

 Share

×
×
  • Create New...