Jump to content
Corsair Community

Bluetooth disappeared


Recommended Posts

I've seen a few others had this problem but I can't see a resolution. My Bluetooth suddenly disappeared today. I have tried to uninstall and reinstall the latest drivers but it is still not present. I do however have an unrecognised USB device in device manager. I have the antennas in. It was initally showing up as a hidden device, but after uninstalling and reinstalling the latest BT drivers it is no longer in device manager hidden or otherwise.


I've opened a support ticket, but does anyone have any ideas how to fix it? The device manager error is Port_#0011.Hub_#0001 Unknown USB device (Device Descriptor Request Failed)

Link to comment
Share on other sites

Support answered my ticket - this is what they said and this resolved the problem for me.


1. Unplug the power cord from the unit.

2. At the rear of the unit, locate the small button that reads "Clear CMOS"

3. Press and hold "Clear CMOS" for 25 seconds and release.

4. Reconnect the power cable and power on the system.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...