Jump to content
Corsair Community

Help with Vengeance LPX 32gb 3200MHz


ea182
 Share

Recommended Posts

I just bought a pack of Vengeance LPX DDR4 32Gb (2x16Gb) 3200MHz (CMK32GX4M2B3200C16)

I plugged them into my Mobo,(ASUS ROG Maximus X Hero (Wi-Fi AC))

Patch the bios with the latest version

I activated the bios option X.M.P. in auto, restart and the memory size stays in 8Gb.

I tried A2 and B2, A1 and B1.

I tried manual OC the ram.

 

Checked the RAM option in CPU-Z, and says that the size of the RAM is just 8Gb.(2x4Gb)

 

my question is, did I received the wrong RAMs?

or is a matter of configuration?

 

thanks

RAM.png.8ad3eef687b84ccfb7adf67341e5fae6.png

buy.thumb.jpeg.a2e08051ba306c05c0380b27d7f59de0.jpeg

Edited by ea182
Link to comment
Share on other sites

Where did you buy the kit?

 

Can you please show us a screenshot of CPU-Z SPD Tab and/or Aida64 (Motherboard > SPD) and/or Thaiphoon Burner (EEPROM > Read SPD...)?

 

That should show the actual part number for the modules.

 

 

Hi, i'm not at home, but i have another capture from the BIOS and we can see the part number.. and i checked that in https://www.memorybenchmark.net/

 

and correct me if i'm wrong.. but it says that.. that part number BLS4G4D240FSB.8FBD belongs to a 4Gb Ram...

****.. they messed up the labels and the rams in the factory???

 

*edit* i bought them in amazon.com

1137430099_Partnumber.thumb.jpg.139cfda0864a4f130ef7f92b31951f2b.jpg

benchmark.thumb.png.987af29873d33e465d7d7a7831f12911.png

Link to comment
Share on other sites

More importantly that is not Corsair memory, but a Crucial Ballistix Sport LT module. Now way this was a mishap at the factory.

 

So if you got two of these sold in a Corsair Vengeance LPX packaging, you have either been scammed by the private seller or the shop you bought them at sent you a returned kit from someone that wanted a free upgrade to 2x16GB Corsair Vengeance LPX from his 2x4GB Ballistix LT (returned his old modules to get his money for the LPX back).

Link to comment
Share on other sites

 Share

×
×
  • Create New...