Jump to content
Corsair Community

Corsair K55 Numlock/Capslock issues?


Recommended Posts

Heyyo,

 

I've really wanted a new keyboard for quite some time, and having RGB is a near-to must for me when it comes to computer accessories nowadays. Seeing how within my budget the K55 was as well, it was the perfect buy!

 

The keyboard has been working far beyond my expectations, until last night. All the LED's at the topright stopped working, though the functions themselves worked (CAPSLOCK and NUMLOCK, specifically).

 

I tried installing CUE and clicking around on mostly everything with no progress, leading me to uninstalling it as I saw it as unneeded software (but, is there a way to fix the issue using that software, i'll be glad to install it again).

 

On a good note, reconnecting the keyboard seems to have fixed the LED's, but on a bad note, this is not issues I want with a new product, about a day into use. I've also had to do this twice so far.

 

Should I bite the bullet and plug in my good old Logitech G110 and take this back to the shop first thing tomorrow, or are we rather looking at a firmware/software issue? I've seen people have similar problems, but do we yet have a "waterproof" fix or are we still lost on that?

 

For what it's worth, it seems to happen when I use fullscreen applications, or at the very least, I've seen it happen whenever I sit playing Watch Dogs. But I guess it may, or may not be a coincidence.

 

I've very recently updated my Bios and Chipset drivers for my motherboard (ASUS Z87-K), ensured that I've got the latest windows updates, and "force reinstalled" the generic keyboard drivers via Windows own device manager (following this guide).

 

Thanks a lot in advance!

 

EDIT 1: I NOW HAVE THE CAUSE OF THE ISSUE! (Though not the solution). When I unplug any other USB device, then plug it back in (for example, my headset charger), the Capslock and Numlock LED's freeze. Nice having the issue pinpointed, now for a solution. Anyone?

Edited by Xariez
Link to comment
Share on other sites

I'm having the same issue as you. I think aside from the way you found them to freeze there are other ways. Any dynamic lighting profile freezes mine every few minutes. Sometimes I don't even need to use any of the lock keys, go to use caps lock and they are already frozen. To get them working again I have to reset the board (BIOS mode back to normal polling rate switch).

 

Sit there and just spam the 3 keys they'll probably freeze instantly or within 10-15 seconds or so if you are looking to just test if they'll freeze or not.

 

I posted about this the other day: http://forum.corsair.com/v3/showthread.php?t=175626

 

I have Z370 and the K70, so I really don't know what this issue is tied to because it does not happen on my old PC (Z68 Gigabyte board).

 

Other threads on this issue:

 

http://forum.corsair.com/v3/showthread.php?t=135977 (from 2015 lol..)

http://forum.corsair.com/v3/showthread.php?t=134647 (2014 same issue)

http://forum.corsair.com/v3/showthread.php?t=132322

http://forum.corsair.com/v3/showthread.php?t=164783 (more recent 2017 thread)

 

It's either they are entirely clueless what causes it or don't care lol

Link to comment
Share on other sites

  • 3 years later...

Hey guys, I know this is a super old post but I've been having issues with iCue as well, but only cuz I'm using macOS Big Sur. ckb-next discontinued support for macOS drivers for corsair products much to my dismay.

 

It was so much more intuitive that iCue, lightweight, and it never broke on you.

iCue is clunky, confusing, and hard on performance. (Mind you I'm on a 2015 MacBook Pro with an i5 and 8gb Ram.

 

BUT I FOUND A SOLUTION TO THIS PROBLEM:

 

- First of all, make sure you force update your keyboard and iCue to latest firmware.

- Try "soft reset" for your device (Google)

- If all else fails, as it did for me. Restart your device and make sure the keyboard is plugged into the computer directly, not a USB hub.

 

This is what worked for me. So anyway, sorry for being 3 years late. Hope this helps someone, anyone!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...