Jump to content
Corsair Community

Cant create corsair account


Recommended Posts

So i have a corsair k70 rgb and recently my left alt key has been displaying a different color than its set to in CUE. When i set everything to white the alt key is slightly yellowish. I'm trying to create a corsair account so i can ask tech support for help with a hard reset but i keep getting this error whenever i attempt making an account 002 2D2AA106-1C4B-4A10-A0AA-83B385BC8DA6.
Link to comment
Share on other sites

I've been having the same problem with regards to trying to make an account. Also getting the message "Fix this then resubmit" or something similar, even though all fields are completed, green and T&C's have been accepted. Really frustrating.
Link to comment
Share on other sites

  • Administrators

universe - is any part of your contact info in your password by any chance?

 

Frosty97 - Is it a different email address than what you've used on the forum? If so, try resetting the password.

 

c-attack - Yep, the site was updated on Friday. It now uses the same login system as the support system, but I'm not sure what you mean by "there are other support systems affected as well". Please clarify what you're referring to, thanks.

Link to comment
Share on other sites

i bet it is the same issue with RGB share site being unreachable, and i cant download profiles.

if thats not the reasoning, hopefully the support site will be up so they can tell me WHAT is...

Link to comment
Share on other sites

c-attack - Yep, the site was updated on Friday. It now uses the same login system as the support system, but I'm not sure what you mean by "there are other support systems affected as well". Please clarify what you're referring to, thanks.

 

Earlier today the automatic update features or both Link and CUE were down. The community profile importer within CUE is still down. The software downloads section of the website is missing the current versions of both Link and CUE. Earlier it was 4-5 months out of date. It seems have been changed to more recent versions, but not the current offerings released last month (CUE 2.23 and Link 4.9.5.25). There have been a few other posts asking about these issues. There are also some minor issues about how the products are sorted on the pages, mismatched sort criteria, etc. All minor issues.

 

*I also could not access my support account when I responded to this post initially. I am able to now, but it was extremely slow to load.

Edited by c-attack
Link to comment
Share on other sites

universe - is any part of your contact info in your password by any chance?

 

Frosty97 - Is it a different email address than what you've used on the forum? If so, try resetting the password.

 

c-attack - Yep, the site was updated on Friday. It now uses the same login system as the support system, but I'm not sure what you mean by "there are other support systems affected as well". Please clarify what you're referring to, thanks.

Nope, same email. That being said, i have also tried making an account with an alternative email, still to no avail. Seems like it just doesn't want me to get in touch with support.

Link to comment
Share on other sites

Have been trying over and over to create a support account. I keep getting this error message AN ERROR HAS OCCURRED. PLEASE CONTACT CUSTOMER SERVICE WITH THE FOLLOWING ERROR CODES:

002

30E08AED-38A5-442D-A2B5-E4D28EAEC1B3

 

No idea how to contact customer service since there is no other info in the message.

Link to comment
Share on other sites

  • 3 weeks later...
 Share

×
×
  • Create New...