Jump to content
Corsair Community

Workaround: Headset stating charged, and not charging when low.


Jardie
 Share

Recommended Posts

Hello,

 

I have spotted a few posts regarding charging issues with the Corsair Void 7.1 RGB headset, and would like to leave this post in order to assist others who have encountered this same issue I have worked around.

 

I hope the below helps.

 

Kind Regards,

Jardie

 

-----------------------------------------------------------------

 

Symptoms / Keywords to assist search:

 

Headset always low charge

CUE & Infomic both state charged / turn green respectively

Battery remaining low after leaving plugged in for some time.

 

Error Messages / Keywords to assist search:

 

Battery Low

Battery Critical

Charging Battery

Amber straight to Green infomic light on microphone arm when charging (powered off)

 

Configuration:

 

Windows 10 -

Corsair Utility Engine: 2.23.40

VOID Wireless Dongle Firmware: v. 39.02

 

Possible Cause:

 

Software / Firmware bug causing headset to believe it is charged when in fact is not.

 

Resolution Summary:

 

1) Turn the headset off.

2) Close the Corsair Utility Engine.

4) Unplug the USB supplied Corsair Wireless Dongle.

5) Plug the headset in to charge.

 

Note: that the Amber light remains active long after it would normally turn green.

 

6) Leave the headset to charge for a considerable time

7) Unplug the headset from charge.

8) Plug in the corsair wireless dongle

9) Relaunch corsair utility engine.

 

Note: This should now display your battery at a higher percent. (Note, these steps may have to be repeated if headset remains charged / on but corsair utility engine reads the percentage as 0% - I believe it can become "out of sync" or incorrectly read the battery levels.

Edited by Jardie
Link to comment
Share on other sites

  • 7 months later...

Thank you for this Jardie, this is the first solution that has had my headphones apparently charging.

 

In my case, the headphones simply need to be plugged in, or will occasionally charge but will drop from 70% to critical/dead in around a minute.

 

I have followed your steps and can FINALLY see a charging light. Will report back after a lengthy charge!

Link to comment
Share on other sites

  • 3 months later...
  • 2 months later...

Hi I was suffering these symptoms and tried the workaround, but a couple of things really.

 

It was on amber on my mic indicator for about 30 seconds and then went to green.

 

After about 20 minutes I did steps 7,8,9 - iCUE said there was no device connected, so I assumed I had to turn it on, but not 100% sure because it wasn't in your steps to turn it back on, although it was a step to turn it off.

 

Anyway, iCUE reported it at 45%, instantly dropped to 44%, a minute later down to 24% and then it chimed in to say battery low and it was powering down, and then just died.

 

So, this hasn't worked for me.

Link to comment
Share on other sites

 Share

×
×
  • Create New...