Jump to content
Corsair Community

K70 RGB will not update firmware


madjeff
 Share

Recommended Posts

Hey all! Been a long-time lurker and I've owned my K70 RGB since it was released. I've been having an ongoing issue where CUE says there is a firmware upgrade available (v2.05), but when I try to update it immediately fails with an error message "Failed to load firmware update for K70 RGB". No attempt to download or anything.

 

I'm on the latest version of CUE (2.23.40) but this has been going on for awhile across several CUE releases. I've searched and tried a variety of fixes mentioned on various threads, from setting the permissions on the CUE folder, to making sure I'm on intel USB 3 ports, moved to USB 2 ports, ran as admin, firewall turned off, etc. Nothing seems to be resolving the issue. I've ignored it for a long time as it hasn't been causing any issues, but now it's starting to irritate me. :sunglasse

 

I would just do a manual firmware upgrade but there doesn't seem to be any place to download the firmware outside of the CUE app.

 

Any ideas, or a download location for the current K70 RGB firmware?

 

Win10Pro x65 / Asus Maximus VII Hero / Asus Strix GTX1080

Link to comment
Share on other sites

So no one else is having this issue? I guess I'll startup a ticket with Corsair support and see if I can get some guidance.

 

Hi,

 

I too have the exact same issue, with CUE v2.24.35 and firmware v2.05.

Each try for updating the firmware fails regardless of the CUE version.

 

May you please post the Corsair's feedback regarding your ticket ? Did they send you the firmware file ?

 

Thanks, and good luck

Link to comment
Share on other sites

  • 5 weeks later...

I've had this issue for a while now. Even after the recent CUE update (2.24.50) still getting the problem.

K70 RGB running firmware 2.05.

Everytime CUE starts it says there's a firmware update - whenever I attempt to apply it: Failed to load firmware update for K70 RGB.

 

Looking in the logs shows:

2018-04-24T09:52:05 I cue.download.fw: FW update available for "K70 RGB" BLD & FW: "0.09" "2.05" On server "0.11" "2.05"

2018-04-24T09:52:22 W QObject::connect: invalid null parameter

2018-04-24T09:52:22 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-04-24T09:52:22 W file:///C:/Program Files (x86)/Corsair/Corsair Utility Engine/QtQuick/Dialogs/DefaultFileDialog.qml:210:25: QML ListView: Binding loop detected for property "model"

2018-04-24T09:52:24 I cue.download.fw: Incorrect index contents: condition for "image-priority" is empty

2018-04-24T09:52:25 C cue.download.fw: Version mismatch.

 

Looks like I have the latest firmware version (2.05), but not the latest build of the firmware (0.09 vs 0.11).

 

Any ideas?

Link to comment
Share on other sites

Just following up on this. I finally opened a support ticket and got my issue resolved.

 

They had me run through a bunch of basic steps, but finally they sent me the 2.05 firmware and a series of steps to reset the firmware and bring up to the latest, and my issue is now resolved.

Link to comment
Share on other sites

Just following up on this. I finally opened a support ticket and got my issue resolved.

 

They had me run through a bunch of basic steps, but finally they sent me the 2.05 firmware and a series of steps to reset the firmware and bring up to the latest, and my issue is now resolved.

 

Hi any chance you could share this please as I have the same issue keyboard on v2.05 build 0.09 but v2.05 build 0.11 on server and refuses to update just saying error.

Link to comment
Share on other sites

Just following up on this. I finally opened a support ticket and got my issue resolved.

 

They had me run through a bunch of basic steps, but finally they sent me the 2.05 firmware and a series of steps to reset the firmware and bring up to the latest, and my issue is now resolved.

 

Whats worse than finding a thread describing the same issue you've had for a year without a solution? Finding a thread where the OP solved the issue but didn't post the solution.

 

Searching online I found steps to reset the firmware on the K70 6 months ago and also a download for the 2.05 firmware but it still doesn't work. Installing the firmware manually the bar completes but then fails at the end.

Link to comment
Share on other sites

  • 4 weeks later...
  • Corsair Employees

Hi Guys,

 

So, I want to illuminate some stuff about this error. CUE will prompt a firmware update for seemingly 2 reasons.

 

1: The keyboard needs a firmware update.

2: The keyboard is not being seen correctly.

 

Most user's who have this issue are experiencing the second one, because most of the keyboards haven't received a firmware update in awhile. Most of you actually have the firmware it is prompting for. It's why the firmware updates aren't working and you receive an error or it freezes.

 

So, how do you get around this?

 

-Soft reset's tend to work for the majority. To do this:

1: Unplug the keyboard.

2: Press the Esc key

3: While holding the Esc key, plug in the keyboard.

4: Hold the key down for 10 seconds.

5: Release the key.

 

-Trying another USB port on the PC can help as well. Try to use the USB ports near the PS/2 port on the PC. These are the old circular ports you used to have to use for keyboards and mice.

 

-Performing a clean reinstall of the software might help. This involves deleting all of the Registry Keys associated with CUE along with the software client. It's easier to use a program like CCleaner or IOBit Uninstaller to do this, so I suggest using those.

 

-Peforming a hard reset might help. This requires a ticket.

 

-Finally, if none of the above work, it may be an actual hardware issue with the keyboard. In this case, we would need to replace it if you are still within warranty.

 

I hope this helps with everyone experiencing this issue.

Link to comment
Share on other sites

is there any chance to get the actually firmware image, because cue2/3 only shows me version 0.01 at my VOID USB 2.05 at my K70 and 2.06 at my M65

 

can i download and install this manually?

 

there is no chance to get this working! Trying the last hours to update my VOID Pro

Link to comment
Share on other sites

My K70 is still failing at firmware update. I have tried the pressing Escape sequence to no avail.

 

It would be handy to have the firmware published on the website so we can update it manually.

 

Yea until someone manages to brick the board through a forced flash...

 

is there any chance to get the actually firmware image, because cue2/3 only shows me version 0.01 at my VOID USB 2.05 at my K70 and 2.06 at my M65

 

can i download and install this manually?

 

there is no chance to get this working! Trying the last hours to update my VOID Pro

 

The latest firmware version for the Void Pro is 0.15. Not all devices will have a similar FW number.

Link to comment
Share on other sites

Yea until someone manages to brick the board through a forced flash...

 

 

 

The latest firmware version for the Void Pro is 0.15. Not all devices will have a similar FW number.

 

but there are some options (like mute mic when fold up) that dosnt work. I thought that were because of the wrong firmware. obviously i have not the latest fm on my Void Pro USB (it shows me 0.01 as the latest)

Link to comment
Share on other sites

but there are some options (like mute mic when fold up) that dosnt work. I thought that were because of the wrong firmware. obviously i have not the latest fm on my Void Pro USB (it shows me 0.01 as the latest)

 

hum, does any of this help? When you are updating make sure you have the headset plugged in directly to the motherboard. Try a different cable, or system.

Link to comment
Share on other sites

hum, does any of this help? When you are updating make sure you have the headset plugged in directly to the motherboard. Try a different cable, or system.

 

i dont have another system, tried various CUE version. i use the Void Pro USB, not wireless, tried every usb port on my computer... Firmware only shows me 0.01 and the mic doesnt turn off when i fold my mic up or rather turn it on if i fold it down

Link to comment
Share on other sites

  • 2 weeks later...

Yep, same issue on the Original K70 RGB. I installed iCUE 3.3.xxx as prompted by CUE 2.24.50. My keyboard goes in an endless loop of getting connected-disconnected. The sound is so annoying. It stops only after I quite iCUE. I tried rolling back to CUE 2.24.50 but the problem still persists. Corsair support hasn't reverted back in 5-6 working days.

 

Now even when I boot the machine, it refuses to load Windows 10, no matter what the polling rate is. Even the BIOS polling rate doesn't work. I have to totally unplug the keyboard to boot windows and plug it in once windows loads. Even after that, I can only use the keyboard in BIOS polling rate mode. Any other polling rate puts my keyboard in the connect-disconnect loop.

 

Corsair really did screw me over. And iCUE/CUE is the only thing I have installed-uninstalled in the past 10 days, nothing else, no GPU update or any other driver update.

Link to comment
Share on other sites

 Share

×
×
  • Create New...