Jump to content
Corsair Community

Hardware Profiles broken Schimitar


Recommended Posts

Everything seems to work when Corsair Cue is running. I'm not always on an OS that supports Corsair Cue. Regardless the issue persists even in windows without Corsair Cue running. Which makes this a hardware issue, not a software issues. If it is software, it's related to the last Cue update, and it's somehow corrupted my device.


I am unable to switch hardware profiles on my mouse or switch DPI. My button mapping is acting erratically as in one button click triggers multiple key commands. For example, shift+command+brackets changes tabs in a web browser. If I tap my button mapped to the above it flys threw my tabs instead of change on tab per click. Even worse if I use my button mapped to command+w which closes a window, it closes several. At this point, my button mappings are muscle memory.


I have tried clearing the internal memory, and I've tried forcing a firmware update. I also have not used any 3rd party drivers to save profiles to my mouse.

Link to comment
Share on other sites

  • 1 month later...
  • Create New...