Jump to content
Corsair Community

Keyboard, mouse and headset stop working when connecting ST100


Gontho
 Share

Recommended Posts

Hello everyone,

 

New user here. Today my Corsair ST100 came in the mail. However, I'm having some severe issues with this product, and I cannot find a single piece of information about this online.

 

Whenever I connect my ST100 to one of my USB ports, my keyboard, mouse and headset all stop working. Sometimes it works for a few seconds and then it just freezes again. It's a really weird issue and I have no idea what causes it. Everything works perfectly fine when the ST100 isn't connected. Switching around my devices in other USB ports doesn't do anything either.

 

Corsair support doesn't offer any help. When creating a support ticket, the ST100 isn't even included as an option. This forum is my last resort now. Any help is much appreciated.

 

Mouse: Trust GXT 152

Keyboard: Razer Blackwidow Chroma V2 Tournament Edition

Headset: HyperX Cloud II

Link to comment
Share on other sites

  • Corsair Employees
Hello everyone,

 

New user here. Today my Corsair ST100 came in the mail. However, I'm having some severe issues with this product, and I cannot find a single piece of information about this online.

 

Whenever I connect my ST100 to one of my USB ports, my keyboard, mouse and headset all stop working. Sometimes it works for a few seconds and then it just freezes again. It's a really weird issue and I have no idea what causes it. Everything works perfectly fine when the ST100 isn't connected. Switching around my devices in other USB ports doesn't do anything either.

 

Corsair support doesn't offer any help. When creating a support ticket, the ST100 isn't even included as an option. This forum is my last resort now. Any help is much appreciated.

 

Mouse: Trust GXT 152

Keyboard: Razer Blackwidow Chroma V2 Tournament Edition

Headset: HyperX Cloud II

 

Try any of the following:

  • Plug the ST100 into a completely different USB controller (usually on the rear of your PC, different USB controllers will be running different rows of USB ports) than what your keyboard/mouse/headset are plugged into.
  • Make sure your ST100 is plugged into at least a USB 3.0 or faster port (USB 3.1)
  • Update your USB controller drivers (you can usually find this at your motherboard manufacturer's support page).

 

Can you also let us know what motherboard/OS you're running?

Link to comment
Share on other sites

 Share

×
×
  • Create New...