Jump to content
Corsair Community

Keyboard and mouse stopped working


Recommended Posts

Hello, I just came across this really weird and irritating problem.

I have the K95 RGB keyboard, harpoon RGB mouse and the void pro RGB wireless headset. They've been functioning nicely for months and I haven't had any problems with them.

While I was working I noticed that the sound wasn't in dolby mode, so I went to the CUE to enable it and I saw that it didn't detect my headset which was weird. I tried to unplug the usb wireless and plug it in again and it made the CUE stop responding, and then my keyboard and mouse stopped lighting up and working.

I tried to restart and then I couldn't log in to my computer because the keyboard and mouse would light up a couple of times and then shut down after the log in screen. I tried accessing the BIOS mode and my keyboard and mouse work perfectly! So I think it's whenever windows loads up, my keyboard and mouse stop working. Please help me fix this! thank you in advance.

 

Edit: I should add that I used other USB keyboard and mouse and they still wouldn't work.

Edited by lukeyoung
Link to comment
Share on other sites

You're very much welcome, however be advised, in my case that procedure (as well as many others...) made my keyboard work for about one day, then it went crazy again, in even worse fashion. I am convinced that the Win update ****ed up the drivers pretty bad, I've done my best to clean them and reinstall but I can't seem to find a permanent solution. Only the Corsair keyboard is affected now, every other peripheral works fine. This is just so you know the solution might not be permanent, hopefully it is for you. If not, I'd also suggest looking into removing the win update AND delaying it as much as possible (to avoid Windows reinstalling it immediately on restart), I have win 10 home and it seems it's not possible to do without Pro version :/
Link to comment
Share on other sites

  • 3 years later...
Ok so I have corsair keyboard and mouse and the same thing is happening now, was working fine and now it's going bonkers. First it starts with keyboard not registering the space button and then just stops typing. Then the mouse does weird things with your clicks. Tried uninstalling and reinstalling. Tried unplugging holding esc and replacing in etc and still nothing??
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...