Jump to content
Corsair Community

Scimitar Pro questions from a complete Noob


itsallpoo
 Share

Recommended Posts

Hi All

 

If there is a specific forum spot for this or somebody's got a tutorial I'd appreciate a pointer. There is youtube stuff but they seem to be for an older model, there are selections in que for different types of button setups maybe I'm just ignorent on which to use?

 

I play black desert online mmo and I bought the scimitar wanting to macro a few keystrokes for functions such as riding skills on the horses and perhaps sailing powers on the big boats. There are a couple of skill combinations that you either need four hands for or a lot more than four fingers on the left hand lol. (namely the sprint, instant acceleration, drift combo that makes your horse look like he's running sublight speeds as the drift resets the cool down on instant accel boosting speed dramatically (like oats with Nos for the hayburner).

 

To run full speed (aka sprint) it is necessary to press w for forward and then hold down the shift key. This works flawlessly on the strafe keyboard but when I try to do this on the scimitar a couple of things happen. 1 i run just fine but I can't figure out how to deactivate it..have tried hitting the key again, escape, using another horse skill nothing and even after i get off the horse the toon keeps wanting to run too (same key combo) so what am I doing wrong? I record the keypress and have tried this with or without the second set of release key release shift in the script no change.

 

NOW FOR THE ANNOYING PART: After I use this macro and then when I plug in the scimitar the next time windows loads some weird keyboard and then I get the caps with lowercase and LOWERCASE WITH NO CAPSLOCK and weird character problem almost like stickykeys got activated...now I know that holding down the shift button activates that at least in versions of windows before 10. I have turned it off every place I can find in windows 10 what am I doing wrong? When it happens it's a pita to find the keyboard setup etc. usually have to log out and use the selector box on the password screen to fix it, then we're fine again until the scimitar gets used again.

 

Last question probably belongs in the keyboard forum but suddenly i get a LOT of multiple key presses when I'm typing. I've corrected the ones in what I just typed here but it's like the keyboard is suddenly hypersensitive if I leave the finger on the key too long i get a dozen of that letter. I tried lowering the poll on the keyboard which seems to have helped and I found a setting in windows and played with that one. I saw a setting while I was sniffing around that ignores multiple key strokes but I think that's part of stickykeys and I do not want that one on at all.

 

PLEASE HELP THE NOOB. I have this issue with overcomplicating everything so that's probably what I'm doing here. thanks!!!!:bigeyes:

Edited by itsallpoo
Link to comment
Share on other sites

1. You will need to check the delays in between the keypress if it's running longer than expected. Removing the release action is the likely cause as to why the action is not stopping.

 

Try this example

Push W

Small delay

Push Shift

X delay

Release shift

small delay

Release W

 

 

2. Try the macro example above and see whether the issue still exists.

 

3. If you purchased a Cherry MX Red or MX Speed keyboard and it is your first time using a mechanical keyboard, this is normal. You will eventually stop pressing the keys.

Link to comment
Share on other sites

 Share

×
×
  • Create New...