Jump to content
Corsair Community

Scimitar needs re-plugging to work


Destrudo
 Share

Recommended Posts

Hello, so I got a k70 RGB LUX and a Scimitar mouse. Cause I really like Corsair.

When I got the keyboard I had the exact same issue but it fixed itself and never bothered me again. But the Scimitar just won't stop.

So the issue is that every time I start the computer the Scimitar won't start. It's lights won't turn on I can't move it and after I login to my account I will see the message that the device is not recognized. Unless I just re-plug it. I had it plugged in the back of my PC but since my tower is quite huge and it's really really annoying to have to re-plug it there, I now have it permanently plugged in the k70's usb port.

On some restart's and some very rare occasions the Scimitar didn't need a re-plug. But these were only 2 or 3 times in total. I have the Scimitar since the November of 2017 since I bought it on Black Friday.

 

So is there a fix for this? I have googled it many times before and saw that many have/had this issue/problem. Also I have them all up to date in the CUE.

Link to comment
Share on other sites

i also have this problem since i bought my scimitar 1 year ago, to bad there's no fix yet

i also have submit ticket, RMA the device, but problem still exist

 

Just wondering if the problem already fixed, then i met this post

can u post here for any fix that support team given

thanks

Link to comment
Share on other sites

i have this problem with this mouse only. i have done all above mentions. i have surfed windows and mother board forums trying to find a common problem. And it isnt every power up, and it isnt when i have a ton or few things plugged in, or where i have it plugged in.
Link to comment
Share on other sites

 Share

×
×
  • Create New...