Jump to content
Corsair Community

Corsair M60 Stopped Working


sharjeelr00
 Share

Recommended Posts

Last night, my Corsair M60 stopped working. I was playing on my desktop when I decided to unplug it and connect it to my laptop to play a different game. The mouse worked fine. I later then plugged it into my desktop and it would not work. The computer detects no input from the mouse: no clicks, no pointer movement, nothing. The two profile DPI selector button on the mouse both light up, however the lights that indicate the selected profile are not lit up.

 

Here's what I've tried:

Uninstalling and reinstalling my drivers. I am met with an error that says something along the lines of "Corsair M60 not detected."

Used the firmware flashing software but given an error that says, "Open USB Device Fail, please reinstall device driver!"

Restarting PC, and repeating above steps did not work.

Plugging it into my laptop and repeating above steps also did not work.

 

If anyone has any other solutions, please let me know! I've been using this mouse for around 4 years and it would be a shame to see it go. Don't really have the money to buy another mouse at the moment.

 

Thanks!

Link to comment
Share on other sites

 Share

×
×
  • Create New...