Jump to content
Corsair Community

Scimitar pro rgb side button issues.


YoloMcWelfare
 Share

Recommended Posts

So I've tried all the fixes I could find which were:

 

Repairing CUE and forcing update which didn't help

 

and updating both the mouse and CUE itself.

 

 

After doing both of those which would be the only solutions I could think of i'm out of ideas on what I could possibly do. Even remapping the buttons after everything didn't work (which some people said would work). The lights on the buttons light up so it can be safe to assume nothing physical is wrong with the mouse. Also what happened to the save button when remapping keys?

 

If anyone has any help they can offer it would be pretty cool.

Link to comment
Share on other sites

So today when I loaded my computer up they keypad worked(well after I had to repair CUE because no device was detected) I'm not going to put the title as [sOLVED] because it really is not.

 

I honestly love corsairs designs and feel of mice but I've always had such deal breaking issues, I just wish my m95 still worked (if i plug it in USB windows doesn't even detect something was plugged in which is weird because i just woke up one day and did nothing.) that was a dream mouse *cough* corsair should make it again.

 

I ended up ordering a Rival 500 last night cause it didn't seem that the mouse would come back to life but it did so now i'll have 2 mice to go back and forth with.

Link to comment
Share on other sites

  • 1 month later...
 Share

×
×
  • Create New...