Jump to content
Corsair Community

Corsair Void Pro - Carbon: Microphone Compatibility Issue with Turtle Beach Z22


MrBlueSky
 Share

Recommended Posts

I recently bought the aforementioned headset because it didn't have an in-line controller, and I wanted to use my Turtle Beach Z22 amplifier to control all of that. It worked great after I opened up the jack entry hole to fit the Corsair headset's plug. The problem is, it suddenly stopped working as intended without warning. The microphone now only picks up output audio (and noise from tapping on the headset). I've gone through every setting to make sure that there is no checkbox causing this, as well as uninstall and reinstall both devices.

 

Using another headset, as well as the original dongle for the Corsair headset, I have verified that both products work fine.

Again, this issue arose out of no where and I am very frustrated. I even did a system restore to when it was working and still no dice.

 

Is there any way to even figure out what is going on? Thank you!

Link to comment
Share on other sites

 Share

×
×
  • Create New...