Jump to content
Corsair Community

Problem with pc building Corsair 570x case


Recommended Posts

I bought a

Corsair 570x case with

 

- EVGA GeForce GTX 1080 Ti

- EVGA SUPERNOVA 650 G3

- AX370-GAMING K7

- CORSAIR H100i v2

- CORSAIR DDR4 VENGERNCE LPX 2x16GB/32GB/3200MHz

- AMD RYZEN 7

 

I build up my pc as supposed to be

I’ve plugged all the cables and so on.

.Atx_12/CPU

ATX/power 24pin

CPU_fan

Sata

F_panel/power sw + -/LED + -

F-audio/hd audio

However, it’s seems that somethings is missing.

Because

The fans of the case is working but the light of fans don’t work

The screen display doesn’t show anything at all

 

EVGA GeForce GTX 1080 Ti has two fans , one of them doesn’t work

What does that mean ??

Link to comment
Share on other sites

double check things are seated properly and that there is nothing grounding out the board anywhere on the rear and that the power switch stuff is connected right.

 

Also the 12v rails both must be plugged into the video card.

 

Is the extra motherboard power plugged in? Theres a many pin one and a four pin one, the both need to be there on modern boards.

 

The jumper for the CMOS reset, comes in many flavors, that is your next step. You may need to physically remove a battery, then shift the jumper over a pin for a time and then put it back and re seat the battery, however that is not always the case these days, theres like a button on some boards...lot of things to try.

 

let us know if that all is in right? toggle the rocker on your power supply

Link to comment
Share on other sites

 Share

×
×
  • Create New...