Jump to content
Corsair Community

H100i V2 Pump Noise


pdatta
 Share

Recommended Posts

Hey guys, I just installed the h100i v2 and noticed it making a weird rattling noise on performance mode but not in quite mode. Please refer to the youtube video I posted, I toggle between performance and quite mode and you can clearly hear the difference! The sound does appear louder on youtube but its still loud enough normally. Please tell me what I should do, Thanks!

 

[ame=

]
[/ame]
Link to comment
Share on other sites

Hi bud... All i can offer is.... my h100i v2 did this a couple of times when new.. now its 12 months old and doesn't make any noise at all.. not saying its normal but it caused me no issues and went away...

 

I always suspected it was air that moved else where once it had all settled....

Link to comment
Share on other sites

I am not hearing anything extraordinary either. You set the pump to maximum and now you can hear it clearly. If you set your fans to maximum, you will here them as well. Kidding aside, it is the same principle. You don’t run your fans at max very often because it isn’t worth the trade off in noise. The pump is similar and there are not any real gains to be had except in long duration, high intensity loads like stress testing, rendering, etc. in those circumstances the fans will be up and you won’t hear it. It the noise becomes high pitched and can be heard over the fans, that is something else. For everyday use, put the pump on quiet mode (2000 rpm) and leave it. It does not matter for most activities.
Link to comment
Share on other sites

 Share

×
×
  • Create New...