Jump to content
Corsair Community

Windows lock button not working for K65 RGB


Recommended Posts

Hi, just got this K65 RBG. When I press the windows lock button nothing happens: the button color does not change and the keys that are supposed to be disabled via CUE (v2.21.67), like the windows key, are still enabled. Similarly the brightness button does not change color when I press it (still not sure what that button is supposed to do). I've tried restarting the computer, deleting all the profiles and starting over, moving the BIOS key from 1 to other positions and back to 1 again, but no luck. What's strange is that when the computer is on the lock screen, the lock button does change color when pressed.


Am I missing something? Must the key somehow be enabled under actions in the CUE?


Help appreciated, thanks!

Link to comment
Share on other sites

Does exiting CUE from the background resolve the Windows lock button?


Tried a firmware reflash via CUE (Force Flash)??


Yes, if I exit the CUE the profile switches to the one that I "saved to device" and the windows lock button does work. So that's interesting, thanks. Unfortunately, when the CUE is not running it won't change profiles depending on the application.


So how do you do a firmware reflash from CUE?


Hm, the little download icon in the lower left says there's a firmware update. Interesting, may try that.


I now have a ticket with Corsair and will relay this info, thanks.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...