Jump to content
Corsair Community

Corsair Void Pro USB 7.1 CUE Problems


Kuraja
 Share

Recommended Posts

So just today I got my new Void Pro, I love how they sound and how they feel, however I have 2 rather big problems. The first one is that I am unable to plug it into any USB except for the front panel USB, I have read this is do to Windows 10's Creator Update which seemed to have installed itself last night.

 

The second problem and the one that is tempting me to return them is whenever CUE is on, I am unable to turn on the MIC. When plugged it would do the beeps that it was turning on then suddenly would say "Mic Off" no matter how many times I hit the mic button or clicked it, the MIC mute indicator would stay on and I would not be able to speak.

 

I really like them and really want to pair them with my M65 and K95 Plat, is there any fix for this issue?

Edited by Kuraja
Link to comment
Share on other sites

So I rolled back to 2.16 and every thing is working great, mic is responsive and I am able to use 7.1. The only problem I still have is that I'm getting an USB recognized (Device Descriptor Request Failed) error. I have a Gigabyte GA-Z77X-UD3H, and I'm using Windows 10 Creator Update. Edited by Kuraja
Link to comment
Share on other sites

  • 4 months later...
I’ve had this Corsair VOID Pro for about six months now, and it has had no problems untill recently. Note:(I’m using this mic on Xbox one) The mic has just stopped picking up my voice and I can’t talk through it anymore. I can hear the audio of the games I am playing through it (I can also hear my friends talking) but it doesn’t pick up my voice. I really do like the mic, but this recent problem is truly frustrating.
Link to comment
Share on other sites

 Share

×
×
  • Create New...