Jump to content
Corsair Community

LL 120 Fan LED gone yellow in one corner


badersama
 Share

Recommended Posts

Hi,

 

I got 6 LL 120 Fans connected to my commander PRO and the RGB controller, I shut down the PC one day and when I came back only fan #1 has light and the rest is dim, so I did as suggested here by some elite members and moved it to another slot, if I move it to #2 then only 2 fans will be lit, if I move it to #6 all of them will be lit, now one issue is also present in addition to that is that the fan has one LED on the outer edge which is dimmed no matter what, also another fan has a yellow hue on one of the LED as shown on the pictures below.

 

by the way I did hook them all up to a different RGB controller and bypassed commander PRO, I even hooked them one by one in isolation and still the same result.

 

Also please note that all fans were working fine for 2 days after I bought them, RMA or is there any possible fix?

 

 

https://imgur.com/jAdqozy

https://imgur.com/vVqp5um

vVqp5um.jpg?1

jAdqozy.jpg

Link to comment
Share on other sites

I would RMA it, personally. All indications are that the fan has an issue. Certainly, the fact that it kills everything else further down the chain is indicative of a problem ... now the problems are increasing.

 

one more fan went dim today, you were right it's infecting the others xD, Ill send em back to Amazon along with the faulty H100i V2 (luck level -99) and maybe get the new AIO instead and try my luck this time.

 

Thanks.

Link to comment
Share on other sites

 Share

×
×
  • Create New...