Jump to content
Corsair Community

K95 NumLock, CapLock and Scroll LED do not work


eddieblade21
 Share

Recommended Posts

PLEASE HELP!!!

 

I have a K95 RGB Platinum, and all of sudden the LED lock indicator , cap lock indicator and scroll indicator doesn't work but the functions do. When i am in the Bios the LED indicator work.

 

I noticed this after i uninstalled Asus Aisuite III, but again it could be a coincident.

 

I try force the firmware, Rebooted several times, move the USB around to different ports, connected them to USB 3.0 and USB 2.0. I dont know what else we know the LED are not burned out.

 

Thank you so much

Eddie

Link to comment
Share on other sites

Well i figure out the issue. I installed a Inateck 5-Port USB 3.0 PCI-E Card KTU3FR-5O2I, thinking i can utilize the 3.0 ports for all my all my K95, R65 Mouse, MM800, G-Drive external drive and the USB 3.0 on the MOBO can be for my Oculus Rift CV1.

 

Everything was working fine until i mentioned that issue yesterday deleting Asus AiSuite III. I connected the Keyboard to a USB 2.0 and works fine. The only issue connecting to the USB 3.0 PCIE is the indicator lights are not working but everything else works, so i switch them to an empty 2.0 port.

 

From what I read if you connect the keyboard to 3.0 do not connect the extra cable, if connecting to 2.0 both cables must be connected.

 

I know this is not a solution for all, but just wanted to send you what resolved my issue

Link to comment
Share on other sites

 Share

×
×
  • Create New...