Jump to content
Corsair Community

CUE causing problems with M65Pro and K55


TheRealBocephus

Recommended Posts

Created a ticket on support:

"Updated my CUE last night and now my M65 Pro RGB is flashing white and will not update and my K55 RGB keyboard is running "incompatible firmware" and I needed to contact support in order to resolve this issue."

 

Responded 5 days later with:

"Please make a clean reinstall of your Corsair Utility Engine. for you to do that please uninstall the program use a ccleaner to clean your registry and install it back again. This will allow you to make a fresh install of your Utility engine."

 

According to Microsoft:

Microsoft’s official position on the use of Registry Cleaners

 

Microsoft does not support the use of registry cleaners

Microsoft is not responsible for issues caused by using a registry cleaning utility.

Microsoft cannot guarantee that problems resulting from the use of a registry cleaning utility can be solved

_____________________________________________________________

 

Can someone solve this or do I just need Razer products?

 

Have reinstalled CUE many times and tried older versions but my mouse is still unplayable. Device manager says ":!:HID Compliant Mouse: This device cannot start. (Code 10)"

 

Update: Using CCleaner did not work.

Link to comment
Share on other sites

Hey there, bud.

 

First off, this is a user forum so it is likely many people are having the same issue - as am I. Using a registry cleaning utility and cleaning only the registries involving Corsair is possible with multiple utilities, and works well. I can walk you through it if you need.

 

Also, passive aggressiveness is only going to get you into trouble, and I really wouldn't like to see you more upset than you already rightfully are - that's not what anyone wants here as a community.

 

If that still doesn't help, I would suggest responding to the ticket and telling them that not only are you still having the issue, but I would link them to this thread because I can say I am having the same issue with my K55 RGB Keyboard, but I am attempting to troubleshoot myself. I only just reinstalled Corsair Utility Engine yesterday after a full system reset.

 

Anyways, let me know how it goes.

 

EDIT: I was able to successfully fix the issue by deleting all device drivers for any keyboards, unplugging the keyboard, and plugging it back in. I then verified the drivers were updated and restarted CUE.

 

Ever since installing CUE, though, no text is shown in the tabs, but I'm 99% confident that is a separate issue.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...