Jump to content
Corsair Community

RGB not working


ChrisBolis
 Share

Recommended Posts

Today i received my new K70 Lux RGB.

When i plugged it into my pc the num, caps and scroll lock leds started flashing and the backlighing wasn't turned on. The keyboard works fine (i'm writing with it) except the rgb leds, windows lock key and the volume thing.

Other then the rgb leds there is another problem: everytime i restart my pc the keyboard stops working completely and i have to plug it in again in my pc just to get the same 3 lights flashing problem described before.

I already tried other usb ports and i tried putting 2 USB 2.0 or 1 USB 3.0.

In the Corsair Utility Engine the keyboard is greyed out and i can click the button to update it but as soon as i click "update" it says that it failed and the keyboard suddently disappears from the software and it says i have no device connected until i plug the keyboard out and in again.

I tried the keyboard in a different pc but it shows the same behavoir (3 lights blinking and all the rest).

Thanks for taking the time to read :biggrin:

Link to comment
Share on other sites

Thanks for the reply but this didn't help, i tried holding page up + page down while plugging back the keyboard but flashing the bios via cue didn't help, i don't really know how to do it: the keyboard is greyed out and if i click "update" as soon as it starts updating is says that the update failed. I tried that but i don't know how to force a flash via CUE, could you please tell me how to do it? :D
Link to comment
Share on other sites

 Share

×
×
  • Create New...