Jump to content
Corsair Community

Link Commander Mini USB Failure


smeezer
 Share

Recommended Posts

So my link commander mini has worked flawlessly for a long time. I had all of my PSU Cables unplugged while I upgraded my system to a custom water cooling loop (which is working flawlessly btw) and upon plugging everything back in and booting up, I got notified there was a link update, did the update and my link commander mini no longer works. My log now says multiple entries of:

 

2017-12-25 03:47:02.0830 | 23 | DESKTOP-******* | 4.9.4.28 | CoolitHidDevice | Cannot open device CorsairLink4.Module.HidDevices.Coolit.CoolitHidDevice

 

This is what I had to disable in Device Manager because it kept cycling and failing, I'm not 100% sure this is related but it's the only thing that's messed up in device manager:

 

HID-compliant device:

HID\VID_2833&PID_0031&MI_00\8&15609A25&0&0000

Hardware ID's as follows:

HID\VID_2833&PID_0031&REV_0708&MI_00

HID\VID_2833&PID_0031&MI_00

HID\VID_2833&UP:0003_U:0005

HID_DEVICE_UP:0003_U:0005

HID_DEVICE

 

It seems to correlate to this in Event Viewer:

Device HID\VID_2833&PID_0330&MI_03\8&d5561be&0&0000 was not migrated due to partial or ambiguous match.

 

Last Device Instance Id: HID\VID_045E&PID_02EA&IG_00\7&6a5f164&0&0000

Class Guid: {745a17a0-74d3-11d0-b6fe-00a0c90f57da}

Location Path:

Migration Rank: 0xF000FC00FFFFF102

Present: false

Status: 0xC0000451

 

 

I dunno if I'm missing something or what but that's what I have at the moment

 

***UPDATE*** Working now, not sure why exactly, steps taken listed below

Edited by smeezer
Solved (I guess)
Link to comment
Share on other sites

So although I had previously tried all the workarounds before, tried attaching link commander mini to a different usb header, this time I switched to another header and unplugged the link cable from the ax1200i from link port 1 to link port 2 (since I went full custom loop and removed the h100i from the system) and now it seems to work fine *throws hands up* not sure what fixed it but it works now.
Link to comment
Share on other sites

 Share

×
×
  • Create New...