Jump to content
Corsair Community

Not Detecting My K70 RGB Keyboard


Recommended Posts

Hi there,


Just downloaded and installed the CUE from the Corsair website, but having rebooted etc. when I run it it just says that there are no devices detected. Keyboard mostly functions fine, although the volume rocker and media controls don't seem to do anything.


It's this keyboard specifically:



Running CUE version 2.21.67, checked for updates and there's nothing available.


Plugged into two USB ports on the back of my desktop PC.


Any ideas for how to get this working? Thank you.

Link to comment
Share on other sites

Is the keyboard in BIOS mode? You will know as this will be indicated by a flashing scroll lock.


If it is in BIOS mode, use the polling switch at the front of the keyboard and move it to BIOS then back to another number.


Man I feel like an idiot now, this fixed it! Thank you!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...