Jump to content
Corsair Community

Issues with LL140 + LL120 Fans in controller?


DangerClose
 Share

Recommended Posts

So I bought a few sets of the new LL140 and LL120 fans. I modded my Carbide 740 so I can fit three of the 140mm fans in the front. I have an H100iv2 in the top and a 140mm fan in the back exhausting air out.

 

My issue is this:

 

with the 6 port LED hub, when I plug the front 140mm fans in ports 1, 2, 3 then the top 120mm fans in ports 4,5 only the port 4 fan lights up.

 

If I plug the 140mm fan in port 6 it does not light up either.

 

If I move them around and plug the 140mm fan in port 4 and move the 120mm fan to port 6 then all of them light up!!

 

It's driving me nuts and I cannot understand why this is happening. Can you not mix 140 and 120mm LL fans in the hub? Why does the controller even care what size the fans are? It shouldn't matter. Oh and I tested this on 2 different 6 port hubs. The Lighting Node Pro has been updated to the latest firmware before anyone asks.

Link to comment
Share on other sites

You can mix 140 and 120's on the same hub ... no problem. The RGB Fan Controller actually has no idea; they both have the same number of LEDs.

However, they are like Christmas tree lights ... on flaky one can take the rest down. It sounds like that's your 120mm fan on port 6 ... it works but there's something amiss that it doesn't pass the signal down the chain and keeps the others from lighting up.

Link to comment
Share on other sites

You can mix 140 and 120's on the same hub ... no problem. The RGB Fan Controller actually has no idea; they both have the same number of LEDs.

However, they are like Christmas tree lights ... on flaky one can take the rest down. It sounds like that's your 120mm fan on port 6 ... it works but there's something amiss that it doesn't pass the signal down the chain and keeps the others from lighting up.

 

Oh man you are right!! I didn't notice it at first but only half of the LEDs on the big ring of that LL120 fan are lit up. These are brand new fans out of the box.....sad that this happened. I wonder if I called Corsair if they would replace it? Bought them on Amazon.

Link to comment
Share on other sites

  • 1 year later...
Oh man you are right!! I didn't notice it at first but only half of the LEDs on the big ring of that LL120 fan are lit up. These are brand new fans out of the box.....sad that this happened. I wonder if I called Corsair if they would replace it? Bought them on Amazon.

 

Yea i noticed on Amazon alot of their units are faulty, which is why I have resorted to either going to local retailer and doing special order or ordering from corsair directly (although expensive shipping from corsair). Amazons defect policy means that alot of ppl are buying new parts and refunding old parts in place of the new one and claiming a DOA to ensure they get a refund since their warranty is over.

 

Nothing corsair can do on it as Corsair does not control who refunds what back to amazon.

Link to comment
Share on other sites

 Share

×
×
  • Create New...